Help Please - Netflix audio Issue with Optical Cable

RoboDog

Active Member
Hi All,

I recently upgraded my stereo amp to an Audiolab 6000A and connected it to my TV (Panasonic Viera 50AS650 - about 5-7 years old) with an optical cable. I watched a video saved on a USB flash drive connected to my TV and the audio on that sounded absolutely fine. Then I tried watching something on Netflix, but all that came from the speakers was white noise. Same issue for Amazon Prime Video. However, audio from videos saved on a USB flash drive are fine.

I've attached photos of the setting screen on my TV. Anything that I need to change? Note that the options for "speaker setting" are "headphone" and "TV speaker". If I select headphone then the white noise comes from the speaker (normal audio when watching a video saved on the USB flash drive). If I select TV speaker then white noise comes from the speaker and normal audio comes from the TV speaker (normal audio from both when watching a video saved on the USB flash drive).

For SPDIF selection - The options are "PCM" and "auto". I tried both but with no joy. Note that the default option was "auto" and I changed it to "PCM" after I have connected all the cables and experienced the issue for the first time, after a quick Google search, but that did not solve it.

Note that my previous amp didn't have any digital inputs so the TV was connected by a standard RCA cable and worked fine. If nothing works then I could switch from optical back to a RCA cable, but I was hoping that there would be a simple solution.

Appreciate any help.

Thanks

TV.jpg
 
Last edited:

Rodders53

Distinguished Member
What about the TV tuner out? Does that work OK as well as the USB stick via the media player/server App?

Check if, when in the awkward non sound playing Apps, there is a sound options menu - it's often a 'per input' on Panny TVs - if so maybe forcing SPDIF to PCM in there will work?

(I seem to recall my GT60 on Netflix has a separate settings for picture and sound that I had to optimise when we got Netflix).

Much streamed content can be 5.1 surround so bitstreamed is often the default but the amp only understands stereo PCM.
 

gibbsy

Moderator
This isn't an amp based issue it to do with your Panasonic set up. Your TV should be set to TV speakers and not headphones. Under Set Up you need to go to audio and set SPDIF to PCM so that the TV converts any 5.1 content to stereo.

This thread may be better off in the Pansonic TV owners' board. I can move it there is you wish. But in any case it needs to be moved to Stereo amps as you're not dealing with an AV amp. Tag me and let me know.
 

RoboDog

Active Member
What about the TV tuner out? Does that work OK as well as the USB stick via the media player/server App?

Check if, when in the awkward non sound playing Apps, there is a sound options menu - it's often a 'per input' on Panny TVs - if so maybe forcing SPDIF to PCM in there will work?

(I seem to recall my GT60 on Netflix has a separate settings for picture and sound that I had to optimise when we got Netflix).

Much streamed content can be 5.1 surround so bitstreamed is often the default but the amp only understands stereo PCM.

TV tuner out? I only watch downloaded content via a USB flash drive and stuff on Netflix and Prime video.

Netflix had a sound option, but the only options were 5.1 and original. It's currently on original, but that hasn't fixed it.

This isn't an amp based issue it to do with your Panasonic set up. Your TV should be set to TV speakers and not headphones. Under Set Up you need to go to audio and set SPDIF to PCM so that the TV converts any 5.1 content to stereo.

This thread may be better off in the Pansonic TV owners' board. I can move it there is you wish. But in any case it needs to be moved to Stereo amps as you're not dealing with an AV amp. Tag me and let me know.

@gibbsy

I have tried it with "TV speakers", but then it plays the white noise on my speakers and normal audio on the TV speakers simultaneously. SPDIF is set to PCM.

Happy for you to move it to the Panasonic TV owners forum. Apologies, I should have done that.
 

Rodders53

Distinguished Member
TV - invokes the TV tuner(s) DVB-T (Freeview) and DVB-S (satellite/freesat) if yours has both.
AV is for external inputs - DVD/Bluray player, PVRs, Apple TV for example.

APPS gets you to the apps selection screen from either TV or AV. Yours may even have a direct Netflix button (a bedroom Panny we have does iirc).

Each of those 'inputs' can have separate 'memory settings' for picture modes (brightness, contrast, etc.,.) and sound modes to suit each device / system.
 

JayCee

Distinguished Member
Power cycle your TV then try the apps.
Your TV speakers should be set to “off” when outputting to an external amp.
 

RoboDog

Active Member
Power cycle your TV then try the apps.
Your TV speakers should be set to “off” when outputting to an external amp.

I've done this but it still didn't work. TV speakers are now set to "off" and SPDIF selection is set to "PCM". Same problem.

APPS gets you to the apps selection screen from either TV or AV. Yours may even have a direct Netflix button (a bedroom Panny we have does iirc).

Each of those 'inputs' can have separate 'memory settings' for picture modes (brightness, contrast, etc.,.) and sound modes to suit each device / system.

I can't seem to find any audio related settings or options for Netflix or Prime video. Could you please let me know how I can access them? I've gone to the "apps" screen, where Netflix, prime video etc. are listed, but there are no settings / options buttons for me to change the setting for individual apps. Furthermore, I can't find any audio related settings in the apps themselves (other than subtitles).

One more point to note - I tried the YouTube app on the TV and the audio on that works fine.
 

JayCee

Distinguished Member
Try this.
Go into your TV's digital audio out settings AND WHILE A NETFLIX PROGRAMME IS PLAYING toggle it to Auto then reselect PCM.
 

Rodders53

Distinguished Member
I can't seem to find any audio related settings or options for Netflix or Prime video. Could you please let me know how I can access them? I've gone to the "apps" screen, where Netflix, prime video etc. are listed, but there are no settings / options buttons for me to change the setting for individual apps. Furthermore, I can't find any audio related settings in the apps themselves (other than subtitles).

One more point to note - I tried the YouTube app on the TV and the audio on that works fine.
Menu ---> Sound --->

The same as with any input/global settings...

My Netflix used Pro 2 picture preset while my DVB-T uses Pro 1.
Sound is Standard vs Music for DVB-T it also has +6dB volume correction (NB probably should also be on Music preset but... that's the trouble with a per App setting ;) ).

My SPDIF is auto on all inputs but my AVR works fine with that.

Note TV speakers: --- leave on just wind the volume down to zero.
IF you had a hdmi avr with arc connection you'd be offered TV speaker and Home Cinema --- then the TV remote would control the amp volume.

When playing a Netflix title it has options -- and I'm offered English (original) or English (original) (5.1) which is ticked on mine on an example title. But PCM ought to get it downmixed by the TV if you've set that correctly?

IIRC pretty much all You Tube stuff is stereo which is probably why it works.
 

RoboDog

Active Member
RCA it is... And it works fine. Thank you all for the help. Unfortunately it seems like a TV / Netflix issue.
 

Andyg400

Active Member
@Rodders53

Just a thanks for your post

I have a Nvida Shield which worked great for Plex, but could I get Netflix to play any sound(+Judder), all sorted changing the HDMI to Bitstream on the panny rather than Auto.

Thanks!
 

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom