Help needed RE Technics RSCH770

Discussion in 'Hi-Fi Stereo Systems & Separates' started by Steviefull, Apr 26, 2007.

  1. Steviefull

    Steviefull
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Not been on this forum often but after some advice, got the above to sell and have a buyer now the important thing to him is the tape deck (for some bizarre reason). The problem that arises is you put a tape in either side hit play it barely starts, stops flips, sides and then stos completely.

    I find it strange that it does it both sides, anyone got any ideas, multiple tapes have been used.

    Thanks in advance
     
  2. Steviefull

    Steviefull
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    so its knackered then?
     
  3. KurtLoeser

    KurtLoeser
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    I had the same problem, and the reason was only the worn-worn belts. I found this: http://www.divdev.fsnet.co.uk/repair3.htm

    At the end it was no problem to order the belts at the Panasonic service: I got them all (four belts two small and two wide) for about 12 EUR (the price was with shipping!, but I had to pay first). This was much more cheaper than in the "special" online shops.

    A friend helped me to repait the deck, but it was simpler then supposed.

    Now it works fine again.


    Bye.

    Kurt
     

Share This Page

Loading...