Help needed from toshiba sd900e owners

Discussion in 'Blu-ray & DVD Players & Recorders' started by jonnyv, May 26, 2003.

  1. jonnyv

    jonnyv
    Active Member

    Joined:
    Mar 31, 2002
    Messages:
    2,152
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +41
    I relaced my power cable a while ago with a russ andrews yello power cable, i plan to make some of the venhaus power cables for my dvd player and amp etc.
    On reading my instruction book for the dvd player it appears that the original power cable has only live and neutral wires,
    Can anyone confirm this for me ?

    thanks
     
  2. Dutch

    Dutch
    Well-known Member

    Joined:
    Dec 5, 2002
    Messages:
    2,597
    Products Owned:
    1
    Products Wanted:
    3
    Trophy Points:
    106
    Location:
    North Yorkshire
    Ratings:
    +282
    Hi jonny,

    My 900E works fine with a RA PowerKord.

    Steve
     
  3. jonnyv

    jonnyv
    Active Member

    Joined:
    Mar 31, 2002
    Messages:
    2,152
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +41
    Dutch, mine works fine also, but i have the option with making my own cables to only use the live and neutral as used in the power cable that comes with the player.
    Do you still have the original cable that you could check for me ?

    Thanks
     
  4. Dutch

    Dutch
    Well-known Member

    Joined:
    Dec 5, 2002
    Messages:
    2,597
    Products Owned:
    1
    Products Wanted:
    3
    Trophy Points:
    106
    Location:
    North Yorkshire
    Ratings:
    +282
    Hi jonny,

    Sorry, I should have read your post correctly. I couldn't find the original lead from the 900E, but if it's any help, my Pioneer 757's original lead only has live and neutral connections.

    Steve
     

Share This Page

Loading...