Quantcast

Question Help me fix sound mode switching on Marantz AV equipment.

azurisk

Active Member
Dear members. I have been having issues with Marantz AV equipment, namely with the automatic sound mode switching. Thisnonly affects those with height channels.I have been in contact with Marantz multiple times for the last few years. As far as I can see all Marantz AV equipment is affected. From the cheapest receiver up to the 8805 processor. I am asking you to call/email Marantz to get this fixed.
The issue is that the receiver won’t automatically switch between 2d and 3d audioformats without enabling the upmixer. I for one would like to have the receiver play what is being put into the machine.
An example.
I want to watch a Netflix show with standard 5.1 sound. I turn on Netflix and start the show. Depending on which sound mode is selected it will play as Dolby Digital +. If not I will select the appropriate mode from the menu (movie - Dolby Digital +). All is fine so far, the receiver will display Dolby Digital + in its display. But the problem is the following. If I now start a show with an Atmos track it will just play as Dolby Digital +. I then need to go into the movie mode menu and select Dolby Atmos, it will then play as Dolby Atmos. But if I go back to a standard 5.1 show that will play as Dolby Digital + + Dolby Surround. I will have to go i to the menu to select Dolby Digital + again to get it to play just that. I hope all of this makes sense.
This issue has been present for years and each time I speak to them they tell me they never heard of the issue and say auto sound mode should do what I want. Except it doesn’t work. If you are experiencing the same issues then please call or send an email to Marantz. Thank you.
 

dante01

Distinguished Member
Why would it matter? Atmos negates Dolby Surround upmixing and DTS:Z negates Neural:X. Neither would be in effect if the receiver detects either Atmos in the case of Dolby Surround or DTS:X metadata in the case of Neural:X.

If Dolby Surround were engaged and active when the receiver detects Atmos metadata then the receiver will not then apply the upmixing and will use the Atmos metadata. You cannot apply Dolby Surround to Atmos encoded audio. The only time the application of upmixing would be an issue is if attempting to apply Neural:X to Atmos, This would negate the Atmos metadata, resulting in you only getting the TRueHD or DD+ base audio with Neural:X upmixing. Likewise, you'd get similar results if attempting to apply Dolby Surround upmixing to DTS:X soundtracks and this would result in you only getting the DTS-HD Master Audio aspect of the audio with Dolby Surround upmixing as opposed to the DTS:X metadata.

Applying Dolby Sirround to DD+ that includes Atmos metadata will not result in you getting just DD+ and Dolby Surround upmixing. The presence of the Atmos metadata negates the Dolby Surround upmixing.


Turn the AUTO feature off and the receiver should cease reverting back to Dolby Surround in relation to Dolby encoded formats dvoid of Atmos metadata. I believe you can use the PURE button to toggle the AUTO mode on and off? Try setting the mode to DIRECT as opposed to AUTO. Avoid the PURE DIRECT option though because this will bypass toom EQ correction and bass management.

Regardless, what you are experiencing isn't exclusive to Marantz AV receivers. Denon receivers behave in exactly the same way. Both DEnon and Marantz are efectively the same concern and share much the same inteface and OS.
 
Last edited:

azurisk

Active Member
You missed the point. I do not want the upmixer to apple to atmos or dtsx. I just do not want to hear the upmixer at all. Without having to select the correct sound modes everytime.
 

dante01

Distinguished Member
THe only option would be to use the receivers PURE or PURE DIRECT modes then.

Yamaha make life a lot simplier with their STRAIGHT mode which would do exactly what you appear to want.
 

azurisk

Active Member
No one else is bothered by the fact that you either can’t play atmos or, if atmos is enabled, always have the upmixer enabled when playing non atmos Dolby signals. I want it to play what is sent and not add extra channels.
 
Last edited:

Rambles

Distinguished Member
No one else is bothered by the fact that you either can’t play atmos or, if atmos is enabled, always have the upmixer enabled. I want it to play what is sent and not add extra channels.
Atmos isn't an upmixer.

It has a core soundtrack of either Dolby Digital plus, or Dolby True HD plus the atmos metadata that is designed to map the height audio to whatever height speakers you have set up on your AVR.

If you are playing back an atmos soundtrack, and you select atmos on your AVR, you are getting the correct audio.
 

azurisk

Active Member
Yes. I know. But I want it to do that automatically. It is ridiculous that I should press buttons to get the correct signal to play/disable the upmixer.

*edited previous post to be a bit more clear.
 

nemesi54

Member
That bothered me a lot also.
I was used that my previous Denon 1910 could auto select the appropriate sound considering what was being fed.

I thought that the Auto selection on the remote button would work but it didnt.
Upmixers where being chosen even though my amp assign is only 7.1 with no atmos or height speakers chosen
I selected manually what i wanted from the various files i had and now it is ok.

When i play DD+ it chooses that, only because i selected it previously, and now its kinda pre-selected everytime i play a file with DD+, or DTS etc.

Yes its frustrating and whats the use of the Auto option then if its not working as it should.
 

azurisk

Active Member
Finally someone who understands what I mean. Might be my writing though, as English is not my primary language.
I was hoping on a larger response and thus hoped we could garner a response from Denon/Marantz
 

494930

Distinguished Member
I understand what you mean as well. It is an annoyance of mine also.
 

glc650

Novice Member
I share this same annoyance.

Also, I've noticed that while I can manually select the correct mode to make non-Atmos Dolby tracks 1:1 (so no upmixing for DD, TrueHD etc.) I'm not able to do the same thing for DTS. If I select DTS-HD MSTR while hearing a DTS-HD 5.1/7.1 track it displays the words correctly on the LCD display but the speaker output still shows my full speaker layout of 7.1.4 (and my ears verify this as well). Anyone else have this issue.
 

azurisk

Active Member
Yes I think this is a bug. If not mistaken you won't hear any sound coming from them. Regarding incorrect switching, I think this will never get fixed. Which is quite ridiculous.
 

glc650

Novice Member
Yes I think this is a bug. If not mistaken you won't hear any sound coming from them.
That's not the case for me. For example, if I manually select DTS-HD MSTR while on a DTS-HD 5.1 track my heights and surround back speakers not only are lit up on the LCD but I can hear sound from them so this is more than a visual/LCD bug for me. With Dolby sound tracks I can at least cycle through the sound modes and select the one specific to the track (DD, DD+, TrueHD) and shut off upmixing that way. Do the Denon AVRs have this bug?

Regarding incorrect switching, I think this will never get fixed. Which is quite ridiculous.
I can get around this fairly effortlessly with the Smart Select buttons. But I agree this is ridiculous, they should at least give us an option to shut off the default behavior of upmix everything. Do the Denon AVRs behave this way?
 

almck

Novice Member
Agree it’s a click of a button to change the input mode and fully agree we really shouldn’t need to do it on a premium AVR receiver (mines a denon x2600h). It should be able to switch automatically between atmos / DD 5.1 / DD 2.1 without applying upmixing on inputs. This is critical when using ARC / EARC when you can’t select a different mode per source or any source that outputs a variety of audio formats (STB)

My 6 year old cheap as chips Samsung HTIB managed this fine (without atmos!).

Is there perhaps a hidden service menu to fix this?
 

Similar threads

Trending threads

Top Bottom