Help me Figure out this problem with my True Wireless Earbuds and my Phone

Gozbot

Novice Member
I have tried to Google this problem and I cannot find any result that resembles this problem. No reviews of these devices mention this issue anywhere, from Amazon to Aliexpress.

You guys are my last hope. Please help me.

I use an Infinix Zero 6 Phone
Here is a Link to the GSM Arena page for the specs.

Here is my journey with three different earbuds.

I ordered my Edifier TWS 1 Pro off the eCommerce Platform Jumia.

The first set arrived and I tested everything.
Everything worked except one thing.

I couldn't hear anything during calls.

When I first made the call, it sounded for 1 second and then the sound went off.

I could hear music playing on the phone and on my laptop but I could not hear anything immediately I hit the dial button to make a call.

If I switched to speaker or headset, I could hear the sound of the ringing.

I called my second device a Zinox Zpad X7 from the Infinix and I could not hear my own voice as I spoke into the microphone of the Zpad.

I connected the earbuds to the Zpad and I called the infinix and the same problem persisted.

I tried everything.

I enabled developer options and I tried the switch the Bluetooth codec to AptX but it just wouldn't change. It kept going back to SBC.

I reset all app preferences but the problem didn't go away.

I figured it was a defective unit and returned it.

I ordered for another Edifier TWS 1 pro.

The second one arrived and I tested the calls immediately. At first it looked like it was not going to work, then it did.

The next day, I was on a call when the sound suddenly went off when another call came in while I was on the first call.

The problem had returned.
I connected to the Zpad and the problem was still there.
I brought a third phone, an Infinix Note 4 and I connected the earbuds, the sound returned. I connected back to my Infinix Zero 6 and the sound was there.

Two days later, the problem returned.
I never bothered to connect it to the third phone. I connected to the Zpad and the problem remained so I just ordered a return.

I decided to go for another model, reasoning that perhaps my phone was not compatible with the TWS 1 pro.

I ordered the Edifier X5.

It arrived and the same problem started. At first, I heard the ringing sound for a second and then it cut off. I didn't hear anything again. The problem was back.

I connected to the Zpad and the problem persisted.
I connected to the Note 4 and the problem persisted.

I took the fourth device. A Xiaomi Redmi 9C which runs android 10.

1. I connect the Earbuds and make a call and I can't hear anything. Then I press the volume down key and I hear the ringing.

2. I switch to my Infinix Zero 6 and I make a call and I can hear the ringing. I press the volume down key and the sound stops.

3. I switch back to the Redmi 9c and repeat step 1, the voice comes back.

4. I connect to the Zinox Zpad 7 and it works. I press the volume down button and the volume up button and it still works.

5. I repeat step 2, same result.

PLEASE WHO CAN HELP ME UNDERSTAND WHAT THE PROBLEM IS AND CAN OFFER ME A PATH TO THE SOLUTION.

Thanks!
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom