Help! Installing TBS 8920 DVB-S2 card Under Ubuntu

edz

Active Member
Hi all

I've just got a TBS 8920 DVB-S2 card to replace my nova tv DVB-S card and i'm trying to change it over but I'm having ...issues.

I'm not a noobie with linux and I've pulled down the latest installation files from the tbs site. I then copied the firmware across and ran the make && make install.

The card now seems to be being picked up but I cant get it to scan.

I'm on Ubuntu 10.04 LTS

uname -ar

Code:
Linux Tardis 2.6.32-32-generic #62-Ubuntu SMP Wed Apr 20 21:54:21 UTC 2011 i686 GNU/Linux

Running dmesg | grep cx88

gives me

Code:
[   21.223415] cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.8 loaded
[   21.223774] cx88[0]: subsystem: 8920:8888, board: TBS 8920 DVB-S/S2 [card=72,autodetected], frontend(s): 1
[   21.223778] cx88[0]: TV tuner type 4, Radio tuner type -1
[   21.418732] cx88/0: cx2388x v4l2 driver version 0.0.8 loaded
[   23.884163] input: cx88 IR (TBS 8920 DVB-S/S2) as /devices/pci0000:00/0000:00:0a.2/rc/rc0/input5
[   23.884256] rc0: cx88 IR (TBS 8920 DVB-S/S2) as /devices/pci0000:00/0000:00:0a.2/rc/rc0
[   23.884262] cx88[0]/2: cx2388x 8802 Driver Manager
[   23.884295] cx88-mpeg driver manager 0000:00:0a.2: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   23.884305] cx88[0]/2: found at 0000:00:0a.2, rev: 5, irq: 18, latency: 32, mmio: 0xec000000
[   23.884315] IRQ 18/cx88[0]: IRQF_DISABLED is not guaranteed on shared IRQs
[   23.884939] cx8800 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   23.884952] cx88[0]/0: found at 0000:00:0a.0, rev: 5, irq: 18, latency: 32, mmio: 0xeb000000
[   23.884966] IRQ 18/cx88[0]: IRQF_DISABLED is not guaranteed on shared IRQs
[   23.885072] cx88[0]/0: registered device video0 [v4l2]
[   23.885107] cx88[0]/0: registered device vbi0
[   25.471492] cx88/2: cx2388x dvb driver version 0.0.8 loaded
[   25.471498] cx88/2: registering cx8802 driver, type: dvb access: shared
[   25.471504] cx88[0]/2: subsystem: 8920:8888, board: TBS 8920 DVB-S/S2 [card=72]
[   25.471509] cx88[0]/2: cx2388x based DVB/ATSC card
[   25.471512] cx8802_alloc_frontends() allocating 1 frontend(s)
[   26.186765] DVB: registering new adapter (cx88[0])

Which looks ok although I'm not sure its loading the firmware.

Trying to scan doesnt work though, using

scan -x0 -a1 Astra*28*E

gives lots of these messages

Code:
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x0010

and kern.log shows

Code:
Jun  7 20:11:36 Tardis kernel: [   48.020054] cx24116_cmd_execute() Firmware not responding
Jun  7 20:11:38 Tardis kernel: [   49.292089] cx24116_cmd_execute() Firmware not responding
Jun  7 20:11:39 Tardis kernel: [   50.564041] cx24116_cmd_execute() Firmware not responding
Jun  7 20:13:31 Tardis kernel: [  162.388013] cx24116_cmd_execute() Firmware not responding
Jun  7 20:13:39 Tardis kernel: [  170.408025] cx24116_cmd_execute() Firmware not responding
Jun  7 20:13:40 Tardis kernel: [  171.444032] cx24116_cmd_execute() Firmware not responding
Jun  7 20:13:41 Tardis kernel: [  172.520015] cx24116_cmd_execute() Firmware not responding
Jun  7 20:14:00 Tardis kernel: [  191.556015] cx24116_cmd_execute() Firmware not responding
Jun  7 20:14:01 Tardis kernel: [  192.632015] cx24116_cmd_execute() Firmware not responding
Jun  7 20:14:11 Tardis kernel: [  202.856019] cx24116_cmd_execute() Firmware not responding

Anyone got any ideas? The forum for tbs is not great and I'm not getting any replies to email. I know this card does work under Ubuntu just seemingly not for me !
 

edz

Active Member
No other Ubuntu users with a 8920 then?

I think I've traced it to the v4l implementation under the 10.04 kernel (I'd updated from 9.10) I'm now going to try updating the box to 10.10 and if that fails this card can go back since there is zero help out there from tbs or - seemingly - anywhere else for these cards under Linux. Yes, there's a driver and its updated on the tbs site - unfortunately it straight out doesnt work in 10.04 upwards.

I've also noted that the installation instructions dont account for Ubuntus removal of development kernel install via apt-get which is probably connected.

If not I suppose its Amazon return policy and a Hauppaguage card being ordered sigh...
 

edz

Active Member
Gave up :(

After 4 days, no response at all from TBS or the supplier and god knows how many hours this card will not scan. Took it out and put the nova (DVB-S only) card back in and it scans first time.

Going to go through the Amazon returns process now and then go for another Hauppauge card - TBS may work very well in Windows 7, may even work in some Linux variants but in ubuntu 9.10,10.04 and 10.10 (the latter two updated to just to try to get this working including custom firmware and patched v4l drivers) I couldnt get anywhere with it :(

Possibly just a bad card but to be honest its the last time I'll try TBS since their cards may be good or may not be but their support is laughably bad.
 

edz

Active Member
TBS *finally* contacted me after I sent them an email saying that they could ignore my previous emails since I was returning the card through Amazon.

The email arrived at 3:45AM and was part chinese (I assume) saying they thought from my details the card was faulty. Since then I've had a couple of emails from the sales managers saying I'd have to send to their address for a refund but by this point i'd already returned using the Amazon returns labels.

Meantime i've ordered this

Hauppauge WinTV Nova S2-HD/Satellite and HD Satellite PCI TV Tuner card: Hauppauge: Amazon.co.uk: Computers & Accessories

Same drivers as my NOVA DVB-S so I should be able swap them out and just retune....I hope
 
Last edited:

edz

Active Member
Have to say Amazon were on the ball, day after I posted the TBS unit back, Amazon confirmed the refund.

New Nova HD should be here around wednesday.

EDIT: Arrived monday 13th (today) so lets hope its a simple job,
 
Last edited:

edz

Active Member
And indeed it went in with no issues.

Retuned Myth and up popped BBC 1 HD, BBC HD, CH4 HD, ITV HD and the long mentioned but not seen before CBS Action, oh and Sky News which I could only get on the freeview tuners previously.

On a side note TBS have emailed me quite a few times to say they had tried to contact me initially, so kudos to them for trying if it was an email issue. Their diagnosis of the issue was the card I had was broken so it wasnt my advancing senility in this case.

After removing all the dross that the freesat scan found and renumbering the channels (why does the myth scanner decide 953312 is a good channel number?) I'm pretty much there - just missing a couple of the very minor channels (we're talking mens movies 2 +1 here) which I'm pretty sure was down to me manually deleting them by accident when removing the dross.

What a fun diversion that was, to recap:

BBC decides to activate the switch to DVB-S2
I freak slightly, order a TBS DVB-S2 Card
It doesnt work, I freak slightly...again
I reinstall drivers, update my mythtv back end
It still doesnt work...
I dont sleep much..
I have to update my front end boxes to support the new .24 myth backend
New linux means I finally update the XBMC camelot instances to Dharma (mmm iPlayer back)
Card still doesn't work
I get cross.....
It goes back..with prejudice!
I order a new Haupagg' card
Amazon play a blinder with returns policy and delivery..
It works...
I go yay..
I retune..
boo...
I fix silly channel numbers...
I go yay
I notice the av 200 powerline adapter in the bedroom has an orange traffic light (low speed)
I sob quietly... (probably a noisy wall wart transformer somewhere in the home office where the myth and unraid servers are, probably plugged into the sockets over by my good lady's desk, probably added recently, not looking until the weekend)

So apart from dealing with any new fun and games that come about from the ubuntu upgrade to 10.10 on the back and front boxes, the new xbmc version and the new 0.24 mythtv instances..... mmm ..... I now have upgraded the systems to be current versions over the 9.10 ubuntu backends they used to be on.

And so endeth (I hope) the blogging :)
 
Last edited:

AntiGrav

Standard Member
Just about to install the TBS-6980 card using this guide on Ubuntu 11.04.

Hopefully will have a better experience than you, as they are quite a lot cheaper than Hauppauge.
 

edz

Active Member
Just about to install the TBS-6980 card using this guide on Ubuntu 11.04.

Hopefully will have a better experience than you, as they are quite a lot cheaper than Hauppauge.

Indeed they are!

£47 for the TBS
£84 for the Haup

Ow!

If you get a card that works (which seemed to be my problem, mine didnt) it seems relatively easy to install.

create /root/tbs
Run the apt-get install commands they suggest (dont have them to hand) I know they include the linux header files for the flavour your using hence the `uname -r` command. NB my instructions said install the develop package that doesnt work anymore as its been removed by ubuntu and I notified TBS about it.

Extract your driver archive into the /root/tbs folder
Extract the archive containing the driver source, mine was the one with 'all' in it
copy or move the .fw firmware driver over into (I think - check this) /lib/firmware
cd into the driver folder
make && make install
Reboot by using shutdown -r now

That *SHOULD* be it. I would then try the szap or the scan command to see if the tuner is playing ball. If you get a lot of firmware not responding messages you're in my world of pain, I fought with that one and TBS seemed to think it meant the card was DOA.

If you get an issue feel free to post back, I'll help if I can since TBS linux support seems to be a hit or miss affair :smashin:
 
Last edited:

edz

Active Member
Truly weird last night the tuners played swapsies on the back end box. First I noted was a failed Freeview recording when I tried the freeview channels they were all unavailable. Thought maybe the transmitter had changed around so tried to reture which found no channels.

Then went into the card setup and noted the devices had changed in myth-setup. Remapped freeview and freesat sources and rescanned and presto all back.

Very bizarre.

Anyone know how to stop pci card allocation slipping about in ubuntu 10.10?
 
Last edited:

revmarkp

Standard Member
hey Edz,

Everything you're talking about here is happening to me! Constant groaning from the family about what a load of rubbish linux and myth is as a result. "Dad, just by a freesat DVR box..." etc etc.

My recent issue is tuners being moved around. Then no live TV and recordings etc. I believe this is mainly a USB issue. I have a PCI Win TV NOVA TD 500 DVB-T tuner which (I understand) is two tuners on the one card that are seen as USB devices; also an external AverTV usb DVB-T tuner, last tuner is a Hauppage DVB-NOVA-HD S2 tuner. Took me about two years getting that one to work! Only really got it going when moved to myth .23 (on .24 now).

My agro with the tuners getting shifted (plugging in my iphone is usually sure to screw it up; usb keyboard, mouse and dvd drive also playing up, which for me confirms this is the issue), has led me to think I should cease to use my main office PC as the myth backend, and setup a more dedicated backend which won't get mucked about with so often. Just started trying to do that, thinking that I would go for dvb-s only (mixing dvb-s and -t has always seemed tricky with the EPG...) only to find I can't get the hauppage card to tune on the fresh box, neither will it tune an old Technisat Skystar 2 card (which I've never got to work actually), even though the kernel appears to see it all fine... so that route is also looking tortuous!

Now thinking I'll google more on usb devices moving in myth. post back if i make progress (Christmas probably!)
 

AntiGrav

Standard Member
My agro with the tuners getting shifted

I had this with Nova-T too. I followed this guide and used udev to create new unique device names. This avoids having to rely on device names as assigned on startup.

I now have problem with the TBS 6981 DVB-S2 card after having compiled and linked drivers to the kernel, the device names have now disappeared after re-boot. Haven't had time to do diagnostics yet.

This Linux HTPC stuff is certainly a challenge :D
 

sudomail

Standard Member
Not sure if anyone is interested now the thread seems to have moved away but I had the same problem with the TBS 8920. Turned out to be the firmware.

run scan-s2 Then run dmesg

You should get an entry in there some like

cx24116_firmware_ondemand: Waiting for firmware upload (dvb-fe-cx24116.fw)...
cx24116_firmware_ondemand: Waiting for firmware upload(2)...
cx24116_load_firmware: FW version 1.23.86.1
cx24116_firmware_ondemand: Firmware upload complete

If not make sure that dvb-fe-cx24116.fw is in /lib/firmware.

If you download the latest drivers from TBS Technologies software|FLYCCCAM|Windows CCCam the firmware is in there.
 

sudomail

Standard Member
This worked with the kernel supplied drivers for 2.6.38. Just had to install the firmware from the TBS website
 

The latest video from AVForums

Podcast: The Best TVs of 2021, plus our favourite & memorable reviews of the year
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom