• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Help! Humax 9200t PVR hangs at start

Quasimodoh

Standard Member
Hi,

I have had a 9200t for a couple of years and been very pleased wit it, however this morning it hung after starting. The boot loader runs, display will show the channel ID and I'll get approx 30 seconds of picture before it hangs, the sound hangs about 10 seconds after that.

I removed the HDD and still get the same issue so it's not related to that. Does anyone have any ideas what might be causing it, there have been no updates recently as AFAIK so don't think it is software related either.

I'm not sure if a run of the mill TV shop would be able to repair one of these so if all else fails my options are to hold out for a freesat PVR when they become available, or pick up a ceap 9200t on ebay (about 70 - 80 GBP when I last looked)

Any advice with the problem or my options would be appreciated.

Q
 

nvingo

Distinguished Member
This query comes up almost daily on Hummy.org.

The almost sure fix is to:
switch off power;
Unplug aerial from aerial input;
Switch on power;
Perform a defaults setting, this will remove all channels from the list (as no signal available);
power off again;
re-connect aerial;
Switch on power;
perform another default setting, this will initiate a channel scan;
you'll need to re-instate scheduled events and personal preferences.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom