Help - Have installers stitched me up?

Hi All,

To cut a long story as short as possible, for the last 2 years ive had one of the original thompson boxes, bought myself over the internet. For quite some time ive had the usual cut outs (Dodgy PSU).

Anyway I called sky and tried to get one of their offers for a new box for £49. After a long struggle it was agreed and the installer came out yesterday. I wasnt here but he tried to install a box by disconnecting old box and plugging in the new one. It goes through a Samsung AVR710 amp/receiver. Thompson box worked fine no probs but apparently some kind of HDCP error kept appearing and he left with cap in hand saying someone would come back tomorrow (Today).

So today arrives, we get a call at 7.45 saying they will be here between 9 and 10. 10.35, 3 guys arrive (Bit mob handed I know).

They say they are here to fit a refurb Amstrad and take my box away. There were 2 things wrong with that statement:

1) Refurb
2) Take my existing box away (As its mine bought outright from internet)

The guys then all leave, go down to the van after saying we'll see what we've got in the van and come back up the stairs with a box. One of the guys goes on to the phone and says im at Paul_HDLovers house and he is refusing to accept a refurb and refusing to give up his old box. Then starts prattling on about a screw up in the order and tells another guy to install the one hes got. So the boy does.

While this goes on, I asked one of the guys if the guy yesterday was installing a refurb to which he areplied along the lines of 'yeah hes a dodgy F*****, he was going to install the refurb and keep the new one for himself'

It should have clicked straight away with me but it didnt until after.

Thye box they took the HD box out of looked old and worn (Not a great indication its a refurb, but doesnt exactly fill me with confidence).

They have fitted an Amstrad drx780uk. There are no noticeable stickers to give away its a refurb. If it were new would it not have the protective plastic accross buttons etc? I dunno.

COMMENT RE HDMI CABLE REMOVED AS I AM NOT SURE ABOUT THIS NOW

They have connected the new HD box up directly to the Samsung LE40R87BDX version SP01

They did not replace the power cable (They have used the old one)

They took away the box packaging including manuals, remote and the box shell itself!

I have just tried to hook up the HDMI cable to my receiver but am getting the message Display does not support HDCP call 08702 XXX XXX.

Help!!

Any technical advice apreciated or just advice on what you would do.

As the HD Box only works when connected directly to the Sammy LCD, it must be something about the receiver?

I have just forced a software update and still no new EPG and I cant access sub HD channels ie SP1 etc as I am getying a message saying 'This is the wrong card for this set top box. Insert the correct viewing card'

To compund things, ive just called sky but getting a recorded message saying THEY are having technical difficulties and to call back later.

:lease::lease::lease::lease::lease::lease::lease::lease::lease:
 
Last edited:
S

sneakyget

Guest
Call SKY and get the installers details tell them what happened also I wound mention the the police in the same conversation. Sounds iffy to me!!
 

Tony Hoyle

Novice Member
Sounds like you've been stitched up.. they had no right to take your old box as it was classed as a new install and definately no right to steal your HDMI cable and packaging. Plus, as you say the 'new' box doesn't even work.

I'd call Sky and put in a formal complaint. Hell, if what you say is accurate I'd be tempted to get the rozzers involved.
 

6022tivo

Novice Member
They left by old box - but took everything else with them...packaging, manuals, remote....

Ring, email sky.

You are entitled to a NEW box, all packing, new leads, new remotes etc.......

You do have 30 days to cancel (Via letter).

Also the installer did not bother to pair up our card to the box... Again, crap, make sure you report all these issues as it does effect his bonus, and so it should. Next time he may do a proper job.
You won't have the new EPG on the amstrad, you will also have poor quality SD and faulty contrast settings on the amstrad as well. Get rid if you can.

Re the DHCP errors, how was the amp connected to the Thomson??? Component???
 
Ring, email sky.

You are entitled to a NEW box, all packing, new leads, new remotes etc.......

You do have 30 days to cancel (Via letter).

Also the installer did not bother to pair up our card to the box... Again, crap, make sure you report all these issues as it does effect his bonus, and so it should. Next time he may do a proper job.
You won't have the new EPG on the amstrad, you will also have poor quality SD and faulty contrast settings on the amstrad as well. Get rid if you can.

Re the DHCP errors, how was the amp connected to the Thomson??? Component???

ive now managed to get sky. they are going to investigate the installer as to why they left with the packaging and contents like manuals and remotes and leads etc as everything in that box was mine.

The thomson box was connected to the receiver with an HDMI cable. There was then an HDMI out from the receiver to the TV. It worked fine (In that respect). The exact same setup with the Amstrad is giving me the HDCP error saying my display doesnt support it. Oddly when I connect HDMI from the Amstrad direct to the TV it works fine. So it must be something to do with the receiver which is a Samsung AVR710. I just cant understand what the difference would be between the thomson and the amstrad in this respect. Surely they should behave the same way.

I dont think i'll manage to get rid of the amstrad now, but yu never know. SD does look a bit single fish, but the HD channels are good.

Its no use to me unless i can overcome this HDCP error though.

Thanks for reply.
 
Update, i've managed to circumvent the HDCP error by taking the sound from the HD Box into the Amp with a digital optical cable. The HDMI then comes straight from the SKY HD box to the TV. This works fine. The only problem is that I can use my receiver as an HDMI switcher, which doesnt cause me any immediate concerns as I dont have another HDMI source (Have a HTPC which users VGA and my Xbox360 is connected via component). But I would have a problem in future if i had another HDMI source.

Anyone know why this box gets an error when routed through my amp but the old thompson never?

A brucy bonus is the old EPG is back.
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom