1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help: FDshow + Zoom Player Pro on a P4 3Ghz results in very jumpy playback?

Discussion in 'Desktop & Laptop Computers Forum' started by tk2001, Jan 8, 2005.

  1. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    Hi,

    I have recently built together a HTPC consisting of a:

    P4 3Ghz Northwood processor
    Asus mATX P4P800-VM Motherboard
    1 gig Crucial 400 DDR ram
    Saphire 9600XT Ultimate
    160 gig SATA Seagate
    Lite-on 812S DVD-RW
    Display is the Hitachi TX-100 at 1280 x 720.

    I have recently installed Zoom Player Pro 4.0.3 along with the latest version of fdshow SSE2 and have used the following decoders with fdshow: windvd 6, power dvd 6 and dscaler 5005 and and I resize fdshow to 1440 x 960 for ntsc dvds and choose Lanczos, the movie playback is very jump and running around 4-5 FPS. The CPU usage is only at 40 % so I can't figure out why the playback is so jumpy.

    Even when I disable the resize on fdshow and just leave everything unticked, the playback is still jump. It's only when I remove fdshow as a filter that playback returns to being smooth again.

    I'm sure the result in jumpy playback is not down to my pc specs but due to some incompatibility problem between the softwares and decoders.

    Does anyone have any idea as to why I get jumpy playwith with fdshow?

    Thanks
     
  2. Kahless725

    Kahless725
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I think it is probably due to one of the sound filters, what filter are you using, try a different one in zoom player. Just as a test disable digital out and see if it jumps then.

    Robert.
     
  3. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    Kahless725,

    I've changed the sound filter to normal stereo and it jumpy playback is still there.

    The weird thing about this is that after I have ticked and enabled 'Resize', and then apply 'Blur & NR' the frame-rate seems to improved quite a bit which is abit strange because you would expect by applying more processing, the framerate to drop, not the other way round.

    I'm only hitting around 50% of my CPU so I can't understand the low frame-rate.

    I am in desperate need of guidance and would really appeciate some further help.

    Thanks
     
  4. KraGorn

    KraGorn
    Active Member

    Joined:
    Aug 30, 2003
    Messages:
    4,740
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    68
    Location:
    Warrington
    Ratings:
    +27
    Are you allowing that 50% on an HT-based system really means 100% (or a tad more) with only one main process running?

    Which order are the filters? If Resize is first and you're not using a post-processor like the nVidia NVPP you could be suffering from colour-space problems.

    I'm no expert on this, merely going on what I read and observe, but by putting a 'do nothing' filter before it then the YUV being output by the MPEG decoder will be converted to YV12 which is what Resize likes. From reading AVS it appears those not using the nVidia codecs often use Denoise with minimum settings for this purpose.
     
  5. Kahless725

    Kahless725
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Try this guide :- http://htpcnews.com/main.php?id=ffdshowdvd_1

    But I would use bicubic as Lanczos is the best resize method and therefore the most taxing on the PC, also turn off the dscaler and let the PowerDVD sw do the deinterlacing.

    All I can think off really. I have only got ffdshow and zoomplayer to work using Powerdvd and NTSC films. I just bought the sonic decoders cos I read that you can flick between NTSC and PAL but now I have it saying that the pins cant connect even though I have done the registry fix for this. Frustrating innit, especially with the ammount of people saying how good it looks when it works.

    Robert.
     
  6. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    KraGorn,

    The 50% CPU usage figure was from the Windows Task Manager not the figure from the OSD from fdshow. I have around the same specs as the guy writing the fdshow guide on the htpcnews wedsite so I am sure I specs must be ok - also he is has his resize resolution alot higher than what I have mine with no problems (1776 x 1000 vs my 1440 x 960)

    Here are my settings:

    Zoom Player Pro (4.0.3)

    Video Decoder: DScaler (5005)

    Audio Decoder: DScaler (SPDIF enabled or disabled makes no difference)

    Audio Renderer: Default Difrect Sound Device

    Video Renderer: Overlay Mixer

    Additional filters: FFDshow Video Processor (20041012-sse2)

    DVD Navigator Filter: Microsoft DVD Navigator


    FFDShow settings:

    Codecs: Raw Video: All Supported

    OSD: Enabled

    Resize & Apsect: Enabled: 1440 x 960

    Settings: Lanczos: Parameter 10. Luma sharpen 1.50. Chroma sharpen 1.50.

    Every other filter/setting from ffdshow is unticked.

    I've just recently downloaded the NVDVD decoder and when I use that with ffdshow all I get is a blank screen.

    KraGorn, what are the specs of your HTPC and whats your CPU usage using ffdshow?
     
  7. nwgarratt

    nwgarratt
    Distinguished Member

    Joined:
    May 5, 2002
    Messages:
    26,332
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,840
    I have recently installed FFDShow and Zoom player. I can only get a picture when using dscaler. Anything else I get class not registered errors.

    I have the same player setup as you wiht the same option enabled. I get a jumpy picture when I resize 1280 x 720 and above. I have a AE100 Pj and when I use 848 x 480 the picture is fine.

    Try reducing the resize figure.

    I only have a AthlonXP 2000 with 512MB RAM and NVidia GForce4 MX440 graphics.
     
  8. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    Kahless725, the main reason I opted for a higher spec PC was to be able to attain the best dvd picture possible and doing a bit of research the general consensus was that a 3Ghz HTPC would be very capable of carrying out that job.

    The guy writing the ffdshow guide has pretty much the same specs as me and he is able use 'Resize' at a higher resolution than me (1776 x 1000 vs my 1440 x 960), use 'Lanczos' and also 'Blur & NR' without any issues of jumpy dvd movie playback so I'm really baffled as to why I am not able to acheive the same results :confused:

    The results from using ffdshow for movie playback (picture wise) has surpassed my expectations. The extra level of detail it brings out and the overall clarity is trully amazing and looks really high-definition.

    Thank you for those who have replied to this thread and any further help will greatly appreciated.
     
  9. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    Hi everyone,

    Just to let everyone know that I managed to get a perfectly smooth dvd playback using ffdshow using Zoom Player Pro and Dscaler decoder.

    I was currently using the 5005 version of dscaler which caused jumpy playback regardless of what settings and filters I used.

    I then decided to download versions 5001 to 5005 and having tried every single one of them, it seems that version 5003 is the best one for my HTPC.

    I can now use what ever ffdshow filter I like such as 'Blur & NR', 'Sharpen' and even up the 'Resize' resolution to 3 times the resolution of an NTSC dvd movie (2160 x 1440) using Lanczos and still achieve a perfectly smooth playback without any stutters and my CPU usage does not go over 60%.

    For all those with a HTPC with around 3Ghz spec, you should easily be able to use ffdshow with perfectly smooth movie playback. Its just a matter of choosing the right decoder for your system. However, the picture quality is simply extraodinary and easily betters the standalone Toshiba SD900E I have owned (which also had superb picture via component.
     
  10. KraGorn

    KraGorn
    Active Member

    Joined:
    Aug 30, 2003
    Messages:
    4,740
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    68
    Location:
    Warrington
    Ratings:
    +27
    I'm still not sure I've explained my concern about the CPU usage :) .. if you got to Processes tab in Task Manager, find the process forZoomplayer , if it says 50% in the CPU column then it's using 100% (more or less) of the processor, remember there aren't really 2 CPUs even though Task Manager thinks there are.

    I have a 3.0 Northwood, stock speed, 6800GT, TheaterTek 2.06 and FFDSHOW_20041012_SSE2, typically I get 60%-70% 'real' CPU usage (from the CPU graphs) using Lanczos 4 and XSharp 30.
     
  11. tk2001

    tk2001
    Active Member

    Joined:
    Nov 4, 2001
    Messages:
    1,371
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +36
    KraGorn,

    What is the exact method of finding out what CPU usage I'm using with ffdshow?
     
  12. KraGorn

    KraGorn
    Active Member

    Joined:
    Aug 30, 2003
    Messages:
    4,740
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    68
    Location:
    Warrington
    Ratings:
    +27
    Open Task Manager, click Processes, look for the ZoomPlayer process (ZPLAYER.EXE), if you have an HT-enabled P4 multiply the figure in the 'CPU' column by 2 (otherwise use the number as-is) and that's roughy the % of CPU it's using.

    You won't see FFDSHOW listed since it's merely a component that the ZoomPlayer program is using, its' processor usage is bundled with that of the MPEG decoders and anytning else that ZPlayer is using.

    Anything over 45 in the CPU column and you're risking peaking over 100% momentarily which the performance graph will be too coarse to see, 50 means you're definitely clipping as you'll see from the graphs on the Performance tab.
     

Share This Page

Loading...