1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! Denon AVR 3805 issue

Discussion in 'AV Receivers & Amplifiers' started by tpc3416, Jan 31, 2005.

Tags:
  1. tpc3416

    tpc3416
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Can anyone help? I'm a newbie to the site, but somewhat knowledgeable of audio and video. I recently upgraded a Sony hi end surround receiver to the new Denon AVR3805. I have read my 100 pg manual 2x trying to figure out why my dts encoded dvd's wont show up as "dts" or "surround EX" on the Denon 3805 receiver display. I've got my Toshiba dvd hooked up from the dts/bitstream out to the Denon's digital coax 1 input, and when I select "auto" it goes to standard Dolby Digital, and not dts. Bitstream does work and I do get sound if I set my Toshiba dvd player to bitstream. Just nothing with the others. When I manually select DTS, nothing plays. The dvd's I am playing are Mummy (dts 5.1), Fast and Furious (dts 5.1), Star Wars II (5.1 Surround EX), and X-Men (THX which should at least register 5.1 Surround EX). Is it possible the Denon is having trouble recognizing dts signals or is there a simple solution to this madness? Thanks! TC
     
  2. AgeOwns

    AgeOwns
    Standard Member

    Joined:
    Jul 28, 2004
    Messages:
    71
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Location:
    Macclesfield
    Ratings:
    +0
    Are you selecting the DTS track on the DVD player? DVD's usually play dolby digital as standard and you have to select the dts audio track in the on screen setup/languages menu of the DVD...or press the audio button on your dvd remote when the movie is playing to toggle through the audio tracks (commentary etc) until you find the DTS one....

    ...unless of course you ARE manually selected DTS on the DVD....in which case sorry for being of no use what so ever.
     
  3. tpc3416

    tpc3416
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    For some reason I am not getting that option on the dvds remote on screen display. Although these dvd's are labeled dts, it's not showing up as an option with the remote. You can only select bitstream, pcm, or analogue. When you play the dvd, and scroll through the audio options, there is no DTS. They all showed up with my last receiver. I cant imagine the Denon has anything to do with that, as the signal goes from the dvd to the receiver and not backwards. Usually the receiver will select the best output. I have another dvd player - I'll try that to see what happens. It's the craziest thing.
     
  4. phillfyspoon

    phillfyspoon
    Banned

    Joined:
    Oct 21, 2003
    Messages:
    2,128
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Hampshire
    Ratings:
    +76
    U have to select dts from the main menu of the actual dvd itself. It is normally in audio/language options.
     
  5. phillfyspoon

    phillfyspoon
    Banned

    Joined:
    Oct 21, 2003
    Messages:
    2,128
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Hampshire
    Ratings:
    +76
    This is the menu of the film "I robot"
     

    Attached Files:

  6. Jase

    Jase
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    9,341
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    South Coast
    Ratings:
    +834
    DTS tracks won't ever show up as Surround EX on the Denon display. It will show DTS, DTS-ES Matrix, DTS-ES Discrete, DTS+PLiix and maybe DTS+Neo6. The modes available will depend on what format is encoded on the disc (i.e you'll only get DTS-ES Discrete from discs that are encoded in that format).

    As has been suggested, make sure you select the DTS track from the dvd disc's Audio Option/Languages menu. :)
     
  7. tpc3416

    tpc3416
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks gentlemen-got it to work. Great site. I totally forgot you have to go into the "language" section of the dvd menu to access dts. You were absolutely right. I have nothing but praises to say about this new receiver, it's power, and sound. They shipped me the old remote with the black foil display and it's unreadable in daylight. Will see if they'll swap it for the new blue one. Next is to bi-amp my RTi10's. :thumbsup: :suicide:
     

Share This Page

Loading...