Help!!! Denon 7.1 receiver shuts off...

Discussion in 'AV Receivers & Amplifiers' started by lionjr, Dec 28, 2006.

Tags:
Thread Status:
Not open for further replies.
  1. lionjr

    lionjr
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :lease: :lease: :lease: :lease:
    Please somebody help...I've got a Denon 7.1 receiver, I've had it for a few months, every once and awhile, when I've got the sound past volume setting 20, the system shuts off and goes to standby, I usually turn the system back on, lower the volume a bit and it's fine; annoying but it works. Today I was listening to it past 20, the system shut off, but now when I turn it back on, the system display gets to "receiver" and then shuts off...happens every time...thought maybe it was just overheated...but now I think it might be a fuse...has anyone had this happen? Any resolution? And...to make matter worse, I can't find my owner's manual...AND I have a slew of people coming in this weekend for bowl games....help!!!! Thank you!!!!
     
  2. sdb123

    sdb123
    Distinguished Member

    Joined:
    May 17, 2005
    Messages:
    18,181
    Products Owned:
    2
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Rushden, Northants
    Ratings:
    +2,252
  3. LV426

    LV426
    Administrator Staff Member

    Joined:
    Jul 14, 2000
    Messages:
    13,690
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Somewhere in South Yorkshire
    Ratings:
    +6,256
    Closing duplicate thread
     
Thread Status:
Not open for further replies.

Share This Page

Loading...