1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help connecting speaker cables

Discussion in 'Home Cinema Speakers' started by nico35, Sep 17, 2005.

  1. nico35

    nico35
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have had my speakers bi-wired for many years but having just decided to change cable i am back to single wires. This may be a daft question but does it matter which of the two pairs of red and black binding posts you use on each speaker and should it be the same on both speakers? ie top two on the one, same on the other?

    I have tried swapping them around but the sound either seems very bassy or very trebly, not sure why!

    Thanks
     
  2. Jack the lad

    Jack the lad
    Active Member

    Joined:
    Jan 12, 2003
    Messages:
    2,033
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    New Zealand was Nottingham
    Ratings:
    +86
    It sounds like you havent re-connected the binding post shorting links. If you havent you are only connecting to either the main driver or the tweeter. Therefore you will only get high frequencie and no middle/bass and vice-versa :)

    Hope this helps.
     
  3. nico35

    nico35
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I take it these are links i would have got with the speakers but i havent had to use as i was bi-wired?

    I have absolutely no idea where they would be. Are they standard links that can be bought easily? :lease:
     
  4. Jack the lad

    Jack the lad
    Active Member

    Joined:
    Jan 12, 2003
    Messages:
    2,033
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    New Zealand was Nottingham
    Ratings:
    +86
    Yes basically they would have been with the speakers from new. You would most certainly have had to have removed them to bi-wire/amp.

    What speakers are you using?
     
  5. nico35

    nico35
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Using JBL Ti 600s

    I have just found them!

    Thanks for your help mate. :)
     
  6. Jack the lad

    Jack the lad
    Active Member

    Joined:
    Jan 12, 2003
    Messages:
    2,033
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    New Zealand was Nottingham
    Ratings:
    +86
    No worries. Hope it all go well :thumbsup:
     
  7. Troon

    Troon
    Standard Member

    Joined:
    Apr 28, 2005
    Messages:
    151
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +2
    Of course, if you hadn't found them, you could just use a short length of speaker cable instead.
     

Share This Page

Loading...