Help! Asus Rampage II Extreme issues, probable RMA?

Ben!

Standard Member
Hey! It's been a little while since I posted on here, but the help I've recieved in the past has always been great, so here I am :)

So I upgraded my PC to i7 around 6 months ago now, part of which included a new Asus Rampage II extreme board purchased from Overclockers. I installed it along with an i7 965, Blaze RAM etc, all went very smoothly, it ran perfectly.

However, around a month ago I boot up one morning to recieve a Northbridge temp warning (it was very hot, the temp had jumped by around 40-50 degrees if I remember correctly). I should point out here that there was no overclock of any kind on the Northbridge; I changed none of it's settings (although the CPU was overclocked, but rock stable). After about two minutes of me fiddling around with settings/trying to understand what had happened, the PC self powers down. I boot up again, this time it lasted about 30-40 seconds. Another few times & it will no longer POST - it now literally powers on for one second before shutting itself down!

So, is my motherboard fried? There is definitely power to it, so it's not a power supply issue. I have tried re-sitting the heat sink, re-fitting the motherboard, changing/swapping out the RAM, etc etc. Nothing has made any difference. I can think of/find nothing else to try.

It looks like an RMA is on the cards - if so, what is the best way to go about it? Contact Asus directly or go to Overclockers.co.uk for a replacement? Anyone with experience when it comes to ASUS & an RMA?

Thanks for reading, any help would be appreciated!
 

StudioRecorder

Standard Member
how long ago did you buy it? normally within the first year of a warranty you have to return it to where you bought it from as your contract is with them and not asus, however after that (as long as it is still in warranty) you have to return it to the manufacturer. so if i were you i would phone up overclockers and organise for it to be delivered back to them for testing and hopefully a replacement mobo
 

PartyGirl

Active Member
Hiya Ben

This sounds exactly like what happened to my RIIE, after about 6 months, funniy enough :(

I was playing some CoD4 at the time and it just shut down and exibited much the same symptoms as yours. I got a few seconds out of it after the first shut down, then if i tried powering on after that it would come on for like half a second before shutting off again. I had power to the board - LED's and such - but after pressing the power button it would come on and imediately swith off again; it sounded like two very close 'clicks' when pushing the power button - one on and the other as it shut off.

If that sounds like yours then I'm afraid it's RMA time. As you bought the board then it should be a 5 day turnaround from the day OcUK receive the board back.



C.


Edit: oops, just noticed the date on the original post
 

Ben!

Standard Member
A (very) late response from me here! Thanks to the above posters for their input regardless though :thumbsup:

I RMA'd the board via Overclockers & received a replacement within a week or so. Props to them for their service; I arranged the whole thing via their forums, very helpful staff there.

The new board has been running splendidly for a month or so now (I got super lazy about replacing it), so I just hope this doesn't happen again.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom