Help a newbie Denon Netflix atmos

MartinPie

Member
Hello everyone, I’m a bit of a rookie when it comes to AV, I’ve asked this over in the Sony community but thought I might get some useful info from the AV community too.

I have a Denon x4400h setup in 5.1.4 and when I play blu ray connected directly to the amp, it displays Dolby Atmos. When I play Atmos content from Netflix from the TV I get Dolby Digital +. I read Netflix send the atmos signal over dd+ So is that what’s going on? Or should it be displaying Atmos like the Blu rays?

Thanks for any input
 

dante01

Distinguished Member
Streaming services package Atmos metadata with DD+. If playing Atmos sourced via a Blu-ray or UHD disc then the metadata is packaged with HD Dolby True HD. The Streaming srrvices don't use HD formats because it would require more bandwidth so use Dolby Digital PLus to deliver Atmos metadata.

The AV receiver should still indicate ATMOS on its display if it fetects Atmos metadata regardless of whether that metadata id packaged and delivered with Dolby TrueHD or DD+. If the AV receiver isn't indicating that Atmos is present then the chances are that your TV isn't outputting Atmos and may sii[ly be conveying DD+ sans any Atmos metadata to your AV receiver? Npot all TV's include an implementation of streaming service apps that can or will deliver Atmos. Does the Netlix implementation onboard your TV actually have this ability?

If the receiver isn't acknowledging Atmos then no, you'd not be getting it or the AV receiver isn't processing it as such.
 

two2midnight

Distinguished Member
Hello everyone, I’m a bit of a rookie when it comes to AV, I’ve asked this over in the Sony community but thought I might get some useful info from the AV community too.

I have a Denon x4400h setup in 5.1.4 and when I play blu ray connected directly to the amp, it displays Dolby Atmos. When I play Atmos content from Netflix from the TV I get Dolby Digital +. I read Netflix send the atmos signal over dd+ So is that what’s going on? Or should it be displaying Atmos like the Blu rays?

Thanks for any input
It may be that you need to select the atmos processing mode. I had similar problem on my Denon X8500H on first use of TV app atmos.

Try checking available sound processing modes on your X4400 using the movie sound mode button on the remote, look at the AVR display and cycle through the available menu options shown using the remote down/up buttons (or repeatedly press the movie sound mode button).

If you don't see any atmos option on the AVR when doing the above make sure your TV is set up to output atmos. What is the TV?
 

MartinPie

Member
Thanks very much for the replies and the explanation dante01.

The Netflix app says atmos on the content I’m playing and the tv is a Sony x90j. When I cycle through the modes on the Denon amp the only Dolby one available is Dolby digital + when playing the Netflix content.

I followed this similar guide for the A90J to setup the tv
In summary I have:

eARC mode auto
Dolby digital plus output set (when I toggle this the Denon switches from Dolby digital to digital +
Pass through mode auto
Digital audio out auto 1

Not sure if there’s much more I can do, the hdmi cable is a 3m Amazon basics 48mbps, could it be worth swapping that out? Although the tv does detect the receiver is eArc
 

Jay53

Well-known Member
Thanks very much for the replies and the explanation dante01.

The Netflix app says atmos on the content I’m playing and the tv is a Sony x90j. When I cycle through the modes on the Denon amp the only Dolby one available is Dolby digital + when playing the Netflix content.

I followed this similar guide for the A90J to setup the tv
In summary I have:

eARC mode auto
Dolby digital plus output set (when I toggle this the Denon switches from Dolby digital to digital +
Pass through mode auto
Digital audio out auto 1

Not sure if there’s much more I can do, the hdmi cable is a 3m Amazon basics 48mbps, could it be worth swapping that out? Although the tv does detect the receiver is eArc


The bandwidth to support eARC is small and only required a high speed with ethernet cable to your current one should be fine as that's ultra high speed

If the x4400 supports it I would suggest getting the Denon AVR remote app for a smart phone as its much easier to see input/output and see what options are available.

From memory Atmos option only comes up when input contains Atmos. I.e in the netflix title screen where it says Atmos on the description isn't sufficient and needs to be playing.
 
Last edited:

gibbsy

Moderator
If the Denon is showing Atmos from disc then it is set up correctly. You have to look at the TV and the Netflix App. To be able to have Atmos then you have to have the highest subscription to Netflix. The problem is not with the Denon but the delivery of the Dolby Digital Plus and it's associated Atmos metadata.

I have a Denon and there is no problem with Atmos from Amazon Prime, I have Netflix on SkyQ which is sans Atmos. Did nothing on the Denon other than to configure it for an Atmos speaker set up.
 

MartinPie

Member
Once again a big thanks to all for helping.

I have an ultra hd subscription to Netflix, on the Denon amp the input signal is showing Dolby digital + too, but the output shows it’s using the height channels too.

Toggling the sound mode the only Dolby one available is digital +

Does feel like something isn’t quite being recognised correctly from the app/tv
 

MartinPie

Member
One last ditched attempt to fix it, I reset the TV to factory defaults, signed in to google and let it do it's thing. Opened netflix, played some atmos content and there it is input source "Format Dolby Atmos/Digital+" that's on the Denon app. The amp just says "Dolby Atmos"

Thought I'd leave this here in case someone else has issues with a similar setup

Thanks everyone for your input, time and comments
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom