Heated Rear Screen problem

tinaandnigeluk

Standard Member
Can anyone help please?

Heated rear windscreen has just stopped working on a 2004 Rover 25. When it stopped, the light on the switch also stopped working and the fusible link in the fuse box under the bonnet had blown. First time I replaced the fusible link it blew again, however, after removing the relay and inserting it again, a new fusible link has not blown and the light in the switch has come on again. The rear screen still does not work though and having tested the contacts each side there appears to be no power getting to it. Anyone any ideas, as I have never had reason to try fixing a HRW before? Thanks in advance
 

gamingboy

Well-known Member
I'd look at the cable running from the front to the back of the car. Something been cut, or exposed to water to cause the fuse to blow?
 

car-man

Well-known Member
Can anyone help please?

Heated rear windscreen has just stopped working on a 2004 Rover 25. When it stopped, the light on the switch also stopped working and the fusible link in the fuse box under the bonnet had blown. First time I replaced the fusible link it blew again, however, after removing the relay and inserting it again, a new fusible link has not blown and the light in the switch has come on again. The rear screen still does not work though and having tested the contacts each side there appears to be no power getting to it. Anyone any ideas, as I have never had reason to try fixing a HRW before? Thanks in advance


This is an extremely common problem on the Rover 25.

I can't remember the fix for it but your local auto electrician will know, give them a ring and ask.



Edit. I remember a couple I fixed where the wiring coming from the body into the tailgate was broken.

I have also replaced the relay before.
 
Last edited:

The latest video from AVForums

Podcast: Large Screen HDR TV or Projector For Home Cinema + Best of the Month
Support AVForums with Patreon

Top Bottom