• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

HDMI Sound problems :(

WackyZ

Standard Member
Right basically I put in a new motherboard which has an inbuilt graphics card, my old one didn't, and thus I have 2 HDMI slots now instead of just one. Now the one I normally use is of course my external card which is an Nvidia GeForce 9500 GS. My sound settings tell me I have 2 HDMI devices running under Nvidia, it's Windows Vista btw, yet these are incorporated into one block and upon further investigation within the properties it states that the drivers running are only for the internal graphics card. So this brings me to my problem - no sound on my TV coming through on my HDMI, video is completely fine, which begs the question is there a way I can split up my two HDMI audio devices/change it to run for my external graphics card.

Any help given will be received with an abundance of gratitude :thumbsup: so thank you :D
 

andy1249

Distinguished Member
Post the motherboard model # , usually there is a way to completely disable onboard sound and graphics within the Bios. This would be the preferred option as the computer would then only see the relevant device.
 

andy1249

Distinguished Member
The MB manual is available here ,

GIGABYTE - Support&Download - Motherboard - Manual Download

To Enter Bios setup hold down del on startup

Scroll down the menus ,
Go to " Integrated peripherals "

Scroll down to "onboard GPU" and press enter , you can toggle onboard GPU on and off here ( page 42 of the manual ) , scrolling down further brings you to " onboard audio " (page 44 of the manual ) shows how to disable the "onboard audio"

Disable the onboard GPU first , that should have the system set up so that only the HDMI device on your graphics card is seen. That should work for you.

If the graphics card has its own sound driver then you may want to disable the " onboard audio " as well.

When your done changing these values in the Bios press F10 , this will give you the option to save your settings and exit , the computer will then boot up as normal and you should only see the external graphics card.
 
Last edited:

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom