Question HDMI Problem Marantz AV7704 with Epson TW9400

kutsanagi

Well-known Member
Hi guys,

I've come across an issue and wondering if anyone had something similar?

I picked myself a Marantz AV7704 this weekend and I've literally swapped out an AV7702mkii and when I've come to watching something on my Epson TW9400 projector, the projector is saying HDMI signal not supported?

Check the information tab on my AV7704 and it's saying DVI and all the information for supported resolutions are not showing, instead of HDMI for connection?

Had zero problem with the projector, the AV7702mkii before or the cable, removed the cable and placed into ps4 and oppo of both are sending a signal (up to 4K 60 ).....any ideas?

Posted same question on both owners' thread, but thought I'd post here just incase a few more people see it!

Thanks for your time as always and any advice would be truly appreciated.

Kutsanagi.
 
Last edited:

Rock Danger

Distinguished Member
How long is the cable? Is the marantz set to passthru in the menu? Tried an different cable to the Marantz? It's usually that if your menus are in order.
 

kutsanagi

Well-known Member
Thanks. It would appear that there's a problem with the cable, like something has internally broken despite how carfeul I've been with it!

I've a new one on order, different company, I've literally installed it, disconnected it, and reinstalled it and it's broken already! Thought a cable would last longer than 4months!

Thanks for the information though!


Hope you're well? The screen is doing me wonders!
 

Rock Danger

Distinguished Member
Yes all good, glad the screen is working out. Cables from Ruipro or Monoprice slim run Av will handle pretty much everything you throw at it.

I once shoved my PJ back against the wall after connecting the HDMI, and thus ****ting' the cable - it would give me 720p or 1080p depending on the angle or nothing at all, I kid you not! It stayed like that for a year in 1080p angle mode :rotfl:
 

kutsanagi

Well-known Member
Very similar situation, it either gave me a signal or didn't! I look into the cables you mentioned. Thanks!
 

Rock Danger

Distinguished Member
Very similar situation, it either gave me a signal or didn't! I look into the cables you mentioned. Thanks!
@themovierooms See if Dan has any 4K Ruipro cables in stock, they're pretty much bulletproof and have an 8k version coming if not out already.
 

kutsanagi

Well-known Member
Thanks for the information, However in the meantime I have managed to find one on Amazon with a discount code and a great price!
 
Top Bottom