1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDMI problem? - Denon 3910/Supra HDMI/Sony HS50

Discussion in 'Blu-ray & DVD Players & Recorders' started by SSB, May 8, 2005.

  1. SSB

    SSB
    Active Member

    Joined:
    Jun 16, 2003
    Messages:
    1,510
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    North Cumbria
    Ratings:
    +173
    Well it was a toss up between posting in this forum, the cable one or the projector one ...

    I received my Sony HS50 (latest firmware) on Friday. I've got it connected to my Denon 3910 via HDMI - Supra 12m.

    When we were watching a movie last night (the first we've watched using HDMI and the HS50) there were a couple of moments when there were blocks on the screen. They were obviously a digital artifact (never seen it with component) and I'm guessing they are something to do with the HDMI connection.

    The Denon was an ex-demo unit. It passes pluge (which is nice), is multi-region with 04 firmware.

    I know the HDMI cable is relatively long, but I figured that given it's a £140 cable and the equipment at either end of it aren't exactly budget kit, there wouldn't be this problem.

    Now, given that all three pieces of kit are new, which is the likely culprit? My money's on the Denon ... hence the post here.
     
  2. Unlight

    Unlight
    Active Member

    Joined:
    Jan 6, 2003
    Messages:
    1,438
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Belfast
    Ratings:
    +9
    May as well give updating the firmware on the Denon a go :)
     
  3. SSB

    SSB
    Active Member

    Joined:
    Jun 16, 2003
    Messages:
    1,510
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    North Cumbria
    Ratings:
    +173
    Well - I've taken the plunge and done that so hopefully it'll fix it.
     
  4. Eddy Boy

    Eddy Boy
    Active Member

    Joined:
    Dec 9, 2004
    Messages:
    937
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    London
    Ratings:
    +27
    Version 9 is the latest but 6 onwards has modifications for HDMI.
     
  5. SSB

    SSB
    Active Member

    Joined:
    Jun 16, 2003
    Messages:
    1,510
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    North Cumbria
    Ratings:
    +173
    Well - just had a short demo and no immediate problems. Will watch something properly tonight and post back.
     

Share This Page

Loading...