HDMI Matrix Second Ouput Won't Connect

Status
Not open for further replies.

mengez

Established Member
Joined
Sep 5, 2008
Messages
1,039
Reaction score
101
Points
175
Location
Harwich
Recently bought a ClimaxDigital HDMI Matrix 4X2 to send HDMI sources to a secondary area.

Initially the second screen took a bit of trial and error to sync and connect (re-connect cables, powering off etc.), nothing has changed on the system ( I may have powered off the amp or swapped the input, I cant remember), but I now can't get any connection.

Second screen is connected by a 10m HDMi (decent but not mega expensive) to an Onkyo HTX-22HDX which outputs to a Panasonic TX-L32G10B. All of which is new.

Inputs are Sky, PS3 and Streamer, all of which operate fine with matrix on Screen 1, I've also swapped the output over and used output 2 to screen one and it connects no problem, so it's not an issue with output 2, just the connection between the unit and the secondary area.


There are other inputs connected the Onkyo directly and these are fine.

I have emailed the support team and I'm waiting to hear back, but I thought a post here wouldn't do any harm and may throw up some ideas. :thumbsup:

Edit. This is a cabling problem and nothing to do with the unit.

Can a mod please close.
 
Last edited:
Done :)
 
Status
Not open for further replies.

The latest video from AVForums

RESTORATION vs. REVISIONISM: At what point do 4K video and audio 'upgrades' cross the line?
Subscribe to our YouTube channel
Back
Top Bottom