HDMI and Optical problem with Onkyo 606

my naim is

Active Member
Hi,

I am the proud owner of a new Onkyo 606 - and all is going very well, apart from one thing. I have my Sky HD box connected using HDMI and an Optical cable. The Sky box has been setup to output Dolby Digital over the Optical cable.

The problem is with the Onkyo . . . when I go into the HDMI configuration screen, I set "CBL/SAT" to use HDMI3. Then in the Optical Input config screen I set "CBL/SAT" to use OPT1. However, the Onkyo seems to be ignoring (or overriding) the Optical setting and is drawing audio from the HDMI cable instead (which means no 5.1).

I can confirm this because if I set "CBL/SAT" to use an empty HDMI slot I get neither picture nor sound - I would expect the sound to still work if it was coming via Optical. Also if I change the HDMI settings to make "CBL/SAT" use HDMI2 it will automatically change "OPT1" to "HDMI2" in the digital audio input section.

Can anyone shed any light on this?
 

jet3d

Active Member
'ang on, the 606, like my 605 only has 2 optical inputs. if you are using one for your dvd and one for your 360, where on earth are you sticking the sky optical into????:confused:

it may be that because you have already assigned the opticals to the component inputs for your dvd and 360 it will not let you assign it to hdmi aswell. try un-assigning the dvd or 360 first.

hope this makes sense and helps!

edit: has you dvd got co-ax out?
 

Trollslayer

Distinguished Member
Hi,

I am the proud owner of a new Onkyo 606 - and all is going very well, apart from one thing. I have my Sky HD box connected using HDMI and an Optical cable. The Sky box has been setup to output Dolby Digital over the Optical cable.

The problem is with the Onkyo . . . when I go into the HDMI configuration screen, I set "CBL/SAT" to use HDMI3. Then in the Optical Input config screen I set "CBL/SAT" to use OPT1. However, the Onkyo seems to be ignoring (or overriding) the Optical setting and is drawing audio from the HDMI cable instead (which means no 5.1).

I can confirm this because if I set "CBL/SAT" to use an empty HDMI slot I get neither picture nor sound - I would expect the sound to still work if it was coming via Optical. Also if I change the HDMI settings to make "CBL/SAT" use HDMI2 it will automatically change "OPT1" to "HDMI2" in the digital audio input section.

Can anyone shed any light on this?

Have you set the HD box to output DTS? I think this should output 5.1.
 
A

agoodpub

Guest
I had this problem when I set mine up the other day. I also saw several posts on here with the same proble - I thought I would have to use component/optical to get round it. Then I read on page 46 of the manual....

"Press the input selector button for the input selector whose setting you want to change"

"Press the [DIGITAL INPUT] button (I think you have to do this on the amp itself - I couldn't find that button on the remote")

"Press the [DIGITAL INPUT] button repeatedly to select an option." One of these options is OPT1(Auto)

Voila. 5.1 sound from Sky HD/Sky+

HTH.
 

malk

Well-known Member
I had this problem when I set mine up the other day. I also saw several posts on here with the same proble - I thought I would have to use component/optical to get round it. Then I read on page 46 of the manual....

"Press the input selector button for the input selector whose setting you want to change"

"Press the [DIGITAL INPUT] button (I think you have to do this on the amp itself - I couldn't find that button on the remote")

"Press the [DIGITAL INPUT] button repeatedly to select an option." One of these options is OPT1(Auto)

Voila. 5.1 sound from Sky HD/Sky+

HTH.


Ive tried this and i dont get a choice for optical,its hdmi>pcm,or hdmi>dts,orhdmi auto.No choice for optical,ive even got my v+ box,with hdmi audio overide on.Ive tried 2 optical leads,tried both inputs,no opt option.mmmmm

If i just press the digital input button,i only get the choice of analogue or hdmi.


woo hooo,ive done it!!now i know why there is a manual,page 44 component video input set up,do that then fiddle with the digital input.(im a plonker)
 

cjed

Well-known Member
I've got a similar problem with the connection from my Toshiba EP-30 HD-DVD to the 606. If I connect to the 606 with HDMI for both video and sound I get interference on the sound. I thought I'd get around this by running optical as well and using that for the sound. But it seems that having sound on the HDMI overrides the optical for that selector (I have it on VCR).

To get sound from the optical on that channel, I have to unplug the HDMI, then the optical sound works fine. Unfortunately, you can't turn off the sound over HDMI from the EP-30 end, so I can't use my 606 to switch the HDMI video and have the sound on optical :-(
 

malk

Well-known Member
thats a bit of a sh*tter,mind you even before i tried the audio assignment,i switched the hdmi sound to off on my v+ box,and the sound still came out the 606 through hdmi???
Im not being funny or condescending,but have a look at p.44 in the manual,and do the assignment,it should override the signal
 

cjed

Well-known Member
... Im not being funny or condescending,but have a look at p.44 in the manual,and do the assignment,it should override the signal

Well, I went and re-checked this, I'd followed the setup on page 44, but there's small print at the bottom of the 1st column on page 45:
'If you change the input assignment on an HDMI to one of the other inputs (Coax, Optical) be sure to set the "Automatic Audio Input Selection Setup" on page 46 ..'

Sure enough, Page 46 shows how to override the default audio selection for an HDMI input! Normally this is automatically done in the precedence : HDMI > Digital > Analogue. By setting this you can change the precedence to remove HDMI audio (so it becomes Digital > Analogue) or to set it to Analogue only.

The bad news is that although it now plays the optical audio, just having the Toshiba HDMI connected to the amp gives buzzing interference on the audio :-(. So I'm back to having the Tosh EP-30 HDMI direct to the TV and the optical into the SR606.

I wonder is an HDMI repeater might clean-up the problem ? Trouble is they're pretty expensive - could a simple HDMI switch be used instead ?
 

malk

Well-known Member
Well, I went and re-checked this, I'd followed the setup on page 44, but there's small print at the bottom of the 1st column on page 45:
'If you change the input assignment on an HDMI to one of the other inputs (Coax, Optical) be sure to set the "Automatic Audio Input Selection Setup" on page 46 ..'

Sure enough, Page 46 shows how to override the default audio selection for an HDMI input! Normally this is automatically done in the precedence : HDMI > Digital > Analogue. By setting this you can change the precedence to remove HDMI audio (so it becomes Digital > Analogue) or to set it to Analogue only.

The bad news is that although it now plays the optical audio, just having the Toshiba HDMI connected to the amp gives buzzing interference on the audio :-(. So I'm back to having the Tosh EP-30 HDMI direct to the TV and the optical into the SR606.

I wonder is an HDMI repeater might clean-up the problem ? Trouble is they're pretty expensive - could a simple HDMI switch be used instead ?

This is way out of my league mate,i wouldnt know about repeaters etc,can i suggest,theres a bloke on here called Kingfats,hes right clued up on this sort of thing.my god,i wish i could help,but its getting a bit deep for my pitifull knowledge mate.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom