HDMI 1x2 Splitter Output Loss to Raspberry Pi

ccaffrey

Novice Member
Hi all, I'm hoping someone can help with our issue.

Our company uses 1x2 HDMI Splitters and on all 15+ units in use we are intermittently losing feed on one of the outputs. Specifically, the video feed is being lost on a Raspberry Pi module that is encoding our video feed. We have also run the HDMI Splitter output to a Teradek IP Encoder and have experienced no issues here. Interestingly, there is also no feed loss if we eliminate the HDMI splitter and run directly to the Raspberry Pi. There is something unique creating the feed loss when the HDMI Splitter and Raspberry Pi are in series.

Our current troubleshoot is to power cycle the Raspberry Pi which regains the video feed within 10-20 seconds. However, the issue persists and tends to drop every time we do a battery change and intermittently.

Here is our setup:
DJI (Drone) Smart Controller >>> to OREI 1x2 HDMI Splitter >>> Output 1: SportScope EDGE Replay (which is a Raspberry Pi) >>> Output 2 can vary between a Teradek encoder (no issues) or secondary a Raspberry Pi (same feed loss occurs on both)

Additional facts and troubleshooting:
-We have tried using alternate HDMI cords
-We have tried using another brand 1x2 HDMI Splitter with the same functions and the OREI UHD PRO-102 splitter. The result is the same.
-The HDMI resolution output is set to 720p and both IP encoders are set to accept 720p inputs
-The problem persists regardless if the HDMI Splitter Output #2 is connected to a secondary Raspberry Pi or another video encoder.

I'm curious if there is another type of 1x2 HDMI Splitter we should consider using? Is there backend coding that can help the Raspberry Pi to auto refresh the feed on its own if a lapse is detected? I'm not experienced enough in this area to know what may be causing the issue. Any help would be greatly appreciated. Thank you!
 
Last edited:

ccaffrey

Novice Member
Original post edited with an update: We have discovered that feed lost most commonly occurs on the Pi when we execute a drone battery change. I'm still curious if there is some coding that be implemented that 'auto refreshes' the Pi when there is a lapse in video feed? That way we don't need to power cycle each time.
 

Joe Fernand

Distinguished Member
AVForums Sponsor
It sounds like the RASP is going to sleep when no Input signal is detected (presumably the Source stops sending a signal when the battery is being changed?).

You could try disabling any power saving features on the RASP or you could replace the Distribution Amp (splitter) for a unit with decent EDID management or add an EDID manager to the cable which feeds the RASP.

Keep in mind the Comms which runs between devices starts at the Sink (Display/Capture card) end of the chain and works back to the Source.

Joe
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom