philtastic

Member
I have an HDFury AVR Key running the latest firmware, setup between my Nvidia Shield TV (2017) and my Pioneer VSX-1326 and LG E6 4K TV.

The problem is that the receiver doesn't get any Dolby signals from the AVR Key. DTS signals work fine, including DTS-HD MA, but none of Dolby formats work at all.

If I pass the audio back from the TV via optical cable, Dolby works, but is limited to Dolby Digital (as per the optical spec). So I know the Dolby signal is being sent from the Nvidia properly, and I also know that the receiver is capable of processing Dolby signals. Also, if I connect my computer to the VSX-1326 directly via HDMI, it processes all formats of Dolby properly. Same for using a Blu-Ray player. The receiver is perfectly capable of decoding Dolby formats.

I also have two other similar setups running AVR Keys between Nvidia Shield TV Pro (2019) with either a Pioneer SC-99 or Pioneer SC-25, both using LG E6 4K TVs. These setups all work fine, and in fact the Nvidia Shield TV (2017) also works fine with these setups.

So the only conclusion I can reach is that the particular AVR Key attached to the VSX-1326 is either not sending Dolby correctly, such that it cannot be processed by the receiver, or it is not sending Dolby signals at all. Updating the firmware made no difference for this issue.

So how do I fix this?
 

Joe Fernand

Distinguished Member
AVForums Sponsor
What happens if you connect the HTPC or BDP direct to the AVR key?

Are you able to switch the AVR keys around to test them out?

Joe
 

philtastic

Member
What happens if you connect the HTPC or BDP direct to the AVR key?

Are you able to switch the AVR keys around to test them out?

Joe

I haven't tried using the HTPC or the BDP with the AVR Key, because they both have dual HDMI outputs which I use to send the video and audio separately. I could give it a try, though. I'll also try swapping the AVR Keys. Hadn't thought of that, mainly because they are being used in different residences. It would be a good way of knowing if that AVR Key is actually the problem, or not. Thanks!
 

philtastic

Member
So I swapped out the malfunctioning AVR Key with a known working unit, and it appears the AVR Key is at fault, because the other one worked fine.

Strangely, Dolby TrueHD actually works. It's Dolby Digital and DD Plus that don't work properly. This affects Netflix, Amazon Prime Video, and even Plex. But only on DD and DD+ videos, which play no sound at all. Plex sometimes works with the lower end formats, but eventually just craps out, too.

The AVR Key in question is less than a year since purchase, so it should covered by warranty. Has anyone here dealt with HDFury's warranty department? Am I going to have to ship this unit to Taiwan, and then wait for a repair or replacement to be shipped back?
 
Last edited:

Joe Fernand

Distinguished Member
AVForums Sponsor
‘Am I going to have to ship this unit to Taiwan’ - that will depend on where you purchased it from!

Joe
 

Joe Fernand

Distinguished Member
AVForums Sponsor
Rules vary around the globe - here in the UK the contract is between the customer and the supplier so you would be having this discussion with Monoprice Canada or Amazon.

Joe
 

philtastic

Member
I contacted HD Fury's tech support, and they pointed out that there are 3 firmware files that all need to installed when updating the firmware. Looks like I missed one or two the first time I updated the firmware, way back when. I reinstalled all 3 firmware files, and everything appears to working properly now. Clearer updating instructions would have been helpful the first time around.

Solution: Install all 3 firmware files when updating the HD Fury AVR Key.
 

Joe Fernand

Distinguished Member
AVForums Sponsor
Never had an issue with FW updates but good you found the fix.

Joe
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom