HD80 and 24p

Alan Paterson

Active Member
Chaps,
I'm sure I'm being a bit thick here, but I'm using a Sony BDP -S300 set to output [email protected] with a Themescene HD80. The HD80 has the latest version of the firmware added, which should allow 24p.
I've only got one Bluray disc at the moment. It's the UK version of 'Casino Royale' which is being displayed by the projector at 1080p 60hz, not 24p.
I've tried resynching the projector, but it keeps finding 1080p 60hz.
In theory the player ought to be outputting 24p.
Is there something I'm doing wrong or is the UK version of 'Casino Royale' not 24p?
As usual, any help or advice gratefully received.

Alan
PS - I'm very pleased with the HD80 picture quality as I've also been using it with a Toshiba E1 HD-DVD player and it's fantastic.
 

jacko5

Active Member
Chaps,
I'm sure I'm being a bit thick here, but I'm using a Sony BDP -S300 set to output [email protected] with a Themescene HD80. The HD80 has the latest version of the firmware added, which should allow 24p.
I've only got one Bluray disc at the moment. It's the UK version of 'Casino Royale' which is being displayed by the projector at 1080p 60hz, not 24p.
I've tried resynching the projector, but it keeps finding 1080p 60hz.
In theory the player ought to be outputting 24p.
Is there something I'm doing wrong or is the UK version of 'Casino Royale' not 24p?
As usual, any help or advice gratefully received.

Alan
PS - I'm very pleased with the HD80 picture quality as I've also been using it with a Toshiba E1 HD-DVD player and it's fantastic.
Select output to auto. I had the same problem. That should work ok.
 

Alan Paterson

Active Member
Jacko,
Thanks, I tried Auto but that just gave me 60hz - but at least you pointed me in the right direction.
The setting that works on the Sony BDP-S300 is 'Source Direct'.
I can now say I've seen 24p.
To be honest it didn't look all that different to me, but I only watched the crane jumping sequence. Maybe it'll be more like film if I watch a complete movie.
All in all, I get a great deal of satisfaction from the quality of HD & Bluray.
In the past, with other projectors and SD there was alway something 'not quite right'.
I think we're over that hurdle.
By the way, if you haven't seen 'The World's Fastest Indian' then please do.
It's a good story, well told and acted.

Alan
 

Martos

Active Member
I am glad it's not just me having this problem! I have just bought the HD80 and cant get it to lock to 1080P/24 with either PS3 or Toshiba EP35. Both players are set to output it, but as Cougar, am only getting 1080P/60.

I know there was a firmware update recently to fix 1080P/24 issues, but is there a way to check whether I already have this update?
 

Canary_Jules

Well-known Member
I have this problem with my HD-EP30 HD-DVD player. My PS3 runs at 1080/24 through my HD80 with no issues because you can force that mode in the PS3. However, you can't with the Tosh, and maybe that's the case with your Sony player too. I did email Optoma about this and referred them to a thread at AVS where people were saying the same things. Optoma replied that there was no issue at all and that the HD80 worked at 1080/24 with every player capable of it. I have since replied that this isn't in fact the case and asked them to test it further. Either Optoma or Toshiba or both need to correct this in a firmware update.
 

Alan Paterson

Active Member
Here's the link to the Toshiba site to download tthe firmware upgrade for your Toshiba players in case you don't have it.

http://tesc.toshiba.co.uk/Web/ModelLis.nsf/DynamicStatic/HD DVD Firmware?OpenDocument

If you check your player's manual it should tell you where you can see the firmware version - either that or the Toshiba website might have the instructions.

My Sony player & HD80 are now happily working in 1080p 24p, but my Toshiba E1 won't as it only outputs 1080i. It's hard to tell the difference really. I think you'd need awfully sharp eyes.

Alan
 

risbac

Standard Member
Thanks I'm already updated and it still doesn't display 1080/24 on my HD80. This is one of those handshake issues so either Optoma or Tosh need to look into it.

Optoma is going to look at this problem. I have the same problem, my reseller has called them and reported it. Wait and see.
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom