HD700X not working with anything HDCP...HELP!

Purplepills

Standard Member
I have posted this problem before, but since then have narrowed it down to a HDCP problem.

I have an Optoma HD700x, which I use all the time no problem gaming on Xbox. It has worked (rather temperamentally) previously with SkyHD, however now it just displays a black screen. I've tried a Blu Ray player, and get the same result.

I've tried several cables which function fine on TV/monitors, and as the real test, have had the PJ on the Xbox using a 1m cable, and tried to use the Sky App on there. Everything is fine until you choose something to watch, then the screen goes black, sometimes showing the HDCP link lost message. Using a splitter though, the content works fine on a monitor at the same time, but again, the HDCP link is lost to the PJ.

All connections are HDMI, tried lengths down to 1m, all sources set to 720p which the PJ can handle fine.

When it stopped working, I updated to the 3D firmware, this has made no difference.

Could the projector develop a fault where it wont accept HDCP connections? Is there anything atall that can be done to sort this out?

Would really appreciate some help here, I'm completely lost as to what can be done :(
 

The latest video from AVForums

Podcast: Samsung TV Launch & QN95A Neo QLED Review, plus Film & TV news & Reviews
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom