HD quality on philips 42" with PC connected

Discussion in 'Computer Components' started by RickFn, Jan 29, 2009.

  1. RickFn

    RickFn
    Standard Member

    Joined:
    Jan 29, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I am having trouble viewing HD blue-ray MKV files. They play fine and there is no skipping. The problem I have is when I view it on my Philips 42" LCD it doesnt look so HD. Some of these movies I view are in 720p or 1080p but the all look the same. When there are areas of different shades of black it almost looks smudged in various shades of black. I use VLC and MPC to view these MKV files and use the CCCP to view these files. This weekend I uninstalled all my codecs and reinstalled just the CCCP to make sure no other codecs were messing stuff up but to no avail. I still get the same issue. I have a GeForce N260 GTX video card with DVI out puts, which I use a DVI to HDMI plug converter to connect to my 42" Philips LCD tv. Since I have a bigger screen I am forced to run at a lower resolution 1024 X 768, I have other higher resolutions available to me but when I choose them the screen size is funky. I am probably just missing something here but what can I do to get better HD quality on the movies I download? Am I able to get a higher resolution on my desktop as well?


    My PC Specs:
    •Processor: Intel Dual Core E6600 Stock Fan (which is awesome)
    •Motherboard: gigabyte GA-965GM-S2
    •Ram: 2 DDR2 PNY Technologies 1 GB dimm
    •Video Card: MSI N260GTX-T2D896-OC

    My Philips 42" Specs:
    Picture/Display
    •Aspect ratio: 16:9, Widescreen
    •Brightness: 500 cd/m²
    •Dynamic screen contrast: 4000:1
    •Panel resolution: 1366 x 768p
    •Picture enhancement: Pixel Plus 3 HD, Dynamic contrast enhancement, 3/2 - 2/2 motion pull down, 3D Combfilter, Active Control, Progressive Scan
    •Video formats Resolution: 480i ,480p, 720p, 1080i
    •Model: Philips 42PFL5332D 42-Inch LCD HDTV
     
    Last edited: Jan 29, 2009
  2. RockySpieler

    RockySpieler
    Active Member

    Joined:
    May 23, 2005
    Messages:
    1,661
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Snaking the Lineup
    Ratings:
    +115
    Try [email protected] via DVI>HDMI and let the TV overscan the image.

    It may be a throw back to Full RGB (0-255) and Video RGB (15-239) colo(u)r ranges.

    By using 1024x768 the TV may assume Full RGB (0-255) range, using 720p60 may "trick" the TV into using video RGB range.

    As an alternative I would also give VGA a go.
     
  3. RickFn

    RickFn
    Standard Member

    Joined:
    Jan 29, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0

    I did as you stated and while that didnt solve all my issues, it was a big help into getting me to understand exactly how this all works. After doing what you stated I also had to configure the players I use to use the proper codecs within cccp as well. My card does not have vga it just has 2 dvi and 1 s video. I messed with the Nvidia Display panel and found out that I had the settings wrong. When I get home I am going to go into detail what I did so maybe others can look at this post and get help if they are facing simular issues.

    Thank you for all your help, your post got me thinking in the right direction!!
     

Share This Page

Loading...