Having major issues with sleep/PlexKodiConnect since Windows 11

Bossworld

Active Member
I use an HTPC that goes back to S3 sleep when not used for 15 minutes. This has been my setup for years, through various cases and hardware components.

Something has changed, either because of recently upgrading to Windows 11 (most likely candidate) or migrating the streaming devices in the house to a newer version of Kodi.

I use the add-on, PlexKodiConnect.

Issue
An addon in Kodi, 'Advanced Wake On Lan' wakes the PC up as the app starts. I can then browse for media to play, I think I have a 15 minute window before the PC falls back to sleep, in line with the settings above.

If I play a TV show or film, as soon as it finishes, I can't play anything else. The PC has gone back to sleep the second the show has stopped streaming.

Previous behaviour
I believe, I used to get the 15 minute timer at the end of the show, to get chance to pick another one.

What have I done?
  • Enabled 'System unattended sleep timeout' within Control Panel, and also set this to 15 minutes
  • Ensured that 'Multimedia Settings > When Sharing Media > Prevent Idling to Sleep' is enabled
  • Tried various options within Advanced Wake On Lan to send continual packets.
  • Had a brief look at Powercfg /requests

--

The PC isn't falling asleep during streaming, but my assumption is that once the show finishes, the running task that would show up within Powercfg is finished, and the PC is immediately going back to sleep.

Does anyone have any other thoughts as to how I can get a 10 minute window after streaming finishes, to pick the next episode?
 

razy60

Well-known Member
I'd check your power settings in Windows, personally I set mine to sleep = never, it means I have to manually set the PC/HTPC to sleep when I've finished, but it eliminates other potential problems.
 

Bossworld

Active Member
I'd check your power settings in Windows, personally I set mine to sleep = never, it means I have to manually set the PC/HTPC to sleep when I've finished, but it eliminates other potential problems.
Hi, thanks for the reply. Setting it to 'never' isn't an option for me, I've had HTPCs since the mid 00s and always used a combo of S3 sleep and WoL to conserve energy when not in use. Spent many an hour chasing through Event Viewer, sometimes futile but I like to try and fix the source of the issue.

My Power Settings are listed above, I think there's something anew in Windows 11 rather than a change in Kodi/Plex/PKC but can't fathom what, don't think it's likely to be anything relating to SMB or similar.

I've found an AHK script that I'm probably going to try and seems to explain the exact issue -
 

razy60

Well-known Member
Can't disagree, however apart from when I used some specific setups on windows home server I've never had much luck with auto sleep setups so resorted to manually putting it to sleep after use either through remote desktop or physically going to the PC.
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom