Having a problem with wifi signal (two routers connected together)

Matt_C

Distinguished Member
A while ago I set up a LAN/WAN in my mums house, and after a few initial problems it was working fine (and has been for about a year or so). Until recently, when problems with signal strength and drop outs upstairs. This is the brief set up;

DOWNSTAIRS;
Primary ADSL router (D-Link) - internet comes in from BT socket to router, and is broadcast over wifi to laptops, phones, and a wireless printer. IP for this router is 192.168.1.1. DHCP is set to assign from 1.3 onwards (can't remember if I set an upper limit), and 1.2 is reserved for the secondary router (Netgear) upstairs

UPSTAIRS;
Secondary router (Netgear) is connected to the primary router using a long Ethernet cable (previously had been installed to connect a non wifi computer to the primary router). This is MAC assigned to 192.168.1.2 in the primary router DHCP settings.

The SSID and password, and protection etc are all identical, and as said everything was working fine - you could go upstairs and downstairs on the same device with no drop outs of signal issues.

However, a couple weeks ago, a company installed solar panels on my mums roof. These are all hardwired to a control box in the understairs cupboard, and that control box is connected via Ethernet cable to a powerline adapter. Another powerline adapter is plugged in near the primary router, and connected using an Ethernet cable. Makes sense so far.

However, since then the wifi signal upstairs has been crap. I'm sitting in the same room as the secondary router (it's about 4 feet away) and it's showing 1 bar on the Windows signal strength indicator (looking at it's connection properties, it shows 1 bar, poor signal strength, and connected speed of 1.0Mbps. I can't remember what it was before, but it should be 54Mbps since it's an 802.11g router)

It's also getting random drop outs - for no reason the wifi will simply disconnect and be a pain to get back. Sometimes it does, sometimes it doesn't and a reboot is required (of the laptop I mean)

I've done the usual reboots of the routers, checked the connections, etc etc. Even with the Ethernet cable from the powerline adapter disconnected, it's still properly poor, and nothing like it was before.

Signal strength downstairs seems fine, and strangely, my iPhone upstairs also shows full signal and seems fine (and I'm sure before I set all this up, and was running off just one wifi router downstairs, the signal on my iPhone upstairs was very low)

I'm wondering whether the secondary router upstairs simply isn't outputting any wifi signal, so the computers (upstairs) are drawing from the primary router downstairs). But then, I can log onto the secondary router (using 192.168.1.2 in a browser) over wifi while upstairs, so it must be, no?

Very confused.

Also, not sure if it's relevant, but if I log into the primary router via browser, and look at the connected devices, all of the devices are still showing as connected; some of which are turned off, and one isn't even in the house! The IP's range from 1.3 to 1.7, and the wireless printer is something like 1.39. Strangely, the two iphones, and the printer show DHCP release/renew in a smidge under 24hrs, but the other devices (two laptops) show over 2000 hrs till release/renew?

The other odd thing is, if I disconnect from the wifi network on my mums laptop, the network (while disconnected from) shows full signal. Soon as I connect, it drops to one bar?

Lastly, the lights on the routers. Primary router is showing two Ethernet lights (for the backhaul cable to upstairs, and the powerline adapter for the solar panel box), along with power (obviously), wifi, and internet. The secondary router is showing power, wifi and one Ethernet connection - the internet light isn't showing. I presume this is because it's not using it's ADSL function? I can't remember if it was or wasn't showing an internet light before the problems started...
 

Matt_C

Distinguished Member
Right, update... I changed the SSID of the secondary router upstairs to one character difference, crating two networks; one being broadcast from the primary router downstairs, and one from the secondary router upstairs. I then connected this laptop to the wifi network broadcast from the secondary router and the speed and signal strength difference is night and day. Full bars, coverage shows as excellent, even after connecting, and speed of 54Mbps.

So for some reason, when the two routers have the same SSID, it's defaulting the connection to the primary router - which since it's far away (downstairs) means the signal strength is poor.

No idea why though?
 

cjed

Well-known Member
What channels are the two routers using ? Are they fixed channels or set to auto select ? You should have set them up so the channels are fixed and far enough apart to prevent interference. An application you can run on your laptop called inssider is very useful in diagnosing issues like this.
 

mickevh

Distinguished Member
No for some reason, when the two routers have the same SSID, it's defaulting the connection to the primary router - which since it's far away (downstairs) means the signal strength is poor.

No idea why though?

Nor are you likely to be able to solve it. In Wi-Fi LAN's it is the client devices that decide which AP to associate with and if/when to roam between them. For a lot of devices there's nothing you can do about it, you're in the hands of the equipment designer. They are (usually) not constantly "hunting for the best signal." Indeed, some will hang on to a working connection (not matter how "bad" it is) until they absolutely have to roam. SmartPhones are notorious for this (roaming sucks up some precious battery life.) One cannot assume you are talking to a given AP just because you happen to be sat in front of it. As you've observed, your client could be associated with an AP much further away offering poorer service.

Pay attention to your channel tunings: If both AP's are using the same or similar radio channels, you can get interference between them. Ideally, choose two channels from the set [1,6,11.] If you AP's are using the high bandwidth versions of "N" (better that 150mbps link rates is a reasonable indication of such, though it's not a hard and fast rule) then there isn't enough frequency spectrum available to create a non-overlapping channel plan, so just set the channels as far apart as you can. With small SOHO deployments (and SOHO class kit) I wouldn't use "automatic" channel assignment mechanisms, I'd set them manually.

Be sure to understand that you secondary router is only going to obtain an IP address from the primary if you have it configured to use DHCP to do so. Much SOHO equipment uses statically assigned IP addresses (not DHCP) for their LAN address. You may need to review the secondary and see how it is obtaining it's IP address to wnsure there's no duplicates.

Lack of "internet" lamp on your secondary router is expected. As you summise, it think's there's no Internet because nothing is connected to it's WAN/Internet port.
 
Last edited:

Matt_C

Distinguished Member
It's really odd though that it worked fine 'roaming" between them for a year or so (however long I've had it set up this way) and only changed recently to it hanging onto the primary AP. Also that if you disconnect and reconnect, it's seeking out and connecting to the primary AP again. Another thing odd is that it's the computers (laptops) that are doing the "non-roaming" thing, whereas the smartphones (two iPhones) are roaming between them fine (I assume, based on the fact that upstairs and downstairs the iPhones had full signal. When I disconnected the secondary/upstairs AP, the iPhones signal dropped. Likewise, after I changed SSID to make each router broadcast it's own network, and connected an iPhone to the upstairs AP, going downstairs the signal almost fell completely off)

I did look for a way to renew or clear all connected IP's in bother routers settings pages, but couldn't see a way to do so. Which is annoying
 

Matt_C

Distinguished Member
Sorry, meant to add. Channels on each router are fixed - Primary is set to 1 and secondary set to 10. Scanning with iStumbler (not today, since I didn't have my Mac with me) showed other networks using 6. Maybe a new network is using 1 or 10, and that's causing the problem?
 

mickevh

Distinguished Member
Sorry, meant to add. Channels on each router are fixed - Primary is set to 1 and secondary set to 10. Scanning with iStumbler (not today, since I didn't have my Mac with me) showed other networks using 6. Maybe a new network is using 1 or 10, and that's causing the problem?

It's possible. I won't get into the minutia as I'll end up writing a book, but I'd set zone 2 onto C11. If there is something else (Wi-Fi) around on C11, they the two will play nicer together if they use the same channel.

Not sure whether your solar panels are causing a problem, I don't know enough about their construction, but if there's big wodges of metal in them, of they generate some nasty RF (can't think why - aren't they basically passive devices..?) that could effect the signaling conditions in your locale. There's not much I can do about it apart from speculate I'm afraid. There are tales of people installing filing cabinets in offices that ***d up wi-fi and I've seen a case where the installation of of a rack of lockers (metal) "made a difference" albeit that it was a performance drop rather than roaming issues etc.
 

Matt_C

Distinguished Member
Must admit, I never thought about whether the panels could make a difference to it or not. If they did, I'd suspect it to be a performance issue though, like the lockers thing. The panels aren't above the room the second (upstairs AP) is, but they are above the adjacent room, which is the room that is used the most for wifi internet.

I see (I think) why using channel 11 on the secondary AP would be good if there was another device/router locally also on 11, but surely that'd apply to 10 as well? Or is there another reason why 11 is prefered?
 

mickevh

Distinguished Member
It's to do with the way wi-fi assesses whether the airwaves are busy or not before transmitting. Wi-fi has a "listen before talk" paradigm and before sending, a would be transmitter (any transmitter, not just AP's) does something called a Clear Channel Assessment. CCA assesses the "strength" of any other radios in the area, (both wi-fi and non-wi-fi) and if they are above certain thresholds, defers from sending. Part of the CCA mechanism is based on detection of neighbouring wi-fi networks by deed of being able to "listen in" to their packet headers and a thus assess how long the "neighbours" are going to transmit for rather than basically guess (wi-fi packet headers have a "length" value (unlike ethernet) and stations use that length to calculate when they next stand a chance of being able to transmit.) However, in order to be able to grab that info. your wi-fi needs to be tuned in to the same as the neighbouring one.

So for example, if your AP is tuned to C10 and the neighbours are tuned to C11, your wi-fi devices won't be able to "hear" the others in a way they can decode the packet header data and grab the length and will just see it as general background radio noise.

Sorry if that's all a bit technical. TBH, it doesn't sound like you're suffering from such, but it's worth a test.

By way of anecdote, I had a neighbour pop up fairly close to me and fairly loud on a similar but not the same channel as you have and suffered I terrible performance drop off and pretty regular session disconnects. By changing to exactly the same channel, the session drops relented a bit, though throughput was still adversely affected. Of course the best solution is for me to shunt to a channel where none of the neighbours are causing me a problem, but that's becoming increasingly difficult in the block of flats I reside it. In the end, I got a dual band router, and skipped up to the 5GHz waveband which (so far) only I'm using.
 

Matt_C

Distinguished Member
No no, keep it coming - all great info! And even if it isn't 100% pertinent, it's still good to learn this kinda stuff! I'll flick the secondary AP onto 11 when I next swing by. Should I keep the primary AP on 1 or switch that too?
 

mickevh

Distinguished Member
Nah, leave that on C1. You ideally want both your coverage cells on different radio channels so they don't interfere with each other - if both cells channel tunings have non-overlapping frequencies, then both cells can transmit simultaneously which increases the overall throughput of the system as a whole.

Of course, you are most likely to have inter-cell interference issues with your own kit as it's closest together. But because it's yours, you can do something about it by setting up your own channel tuning plan. With the neighbours, they are out of your control, so you just have to do the best you can to work round them.
 

Matt_C

Distinguished Member
I'll have a tinker with it when I can next spend a bit of time there with my own laptop. Thanks for the help and tips!
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom