Have toshiba conned me?

Discussion in 'Blu-ray & DVD Players & Recorders' started by andru, Nov 13, 2002.

  1. andru

    andru
    Active Member

    Joined:
    Aug 26, 2002
    Messages:
    317
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Mid Glamorgan
    Ratings:
    +12
    having read a few reports on this forum regarding the firmware on a sd220 i checked mine and found it was v1.3.I then phoned up toshiba and they have just sent me a replacement with what they said would be v1.5.On checking by doing zoom 6 0 6 zoom i get this on the screen

    Boot rom V1.000
    Main rom V1.300-R2

    in my understanding this is still the old version.
    What makes it worse is that this one sounds like R2-D2 when it is scanning a disk>My old one was perfectly quiet.

    Have they conned me?
     
  2. smallman28

    smallman28
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    How old is the machine,they may not be willing to replace what is a second hand machine for a new one and you may have ended up with a reconditioned unit.
    I would contact them and again and let them know what is wrong it might have just been a genuine mistake.
     
  3. andru

    andru
    Active Member

    Joined:
    Aug 26, 2002
    Messages:
    317
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Mid Glamorgan
    Ratings:
    +12
    i have just contacted them and told them that i only bought it in may this year.They told me the firmware is only on v1.4 not v1.5 like other people say.I demanded a NEW unit not what they send me full of scratches to say i was annoyed is an understatement!
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice