Has Anyone Come Across This Phone App Error Before? (Help Required)

Lucy Van Pelt

Distinguished Member
When I try to upload or update an app on my Samsung Galaxy A21s (had it about 14 months, an upgrade from EE who I have been with since 2003) it asks me to select Google Play and it just comes up with the image below

It has been going on for a few weeks now

Tried getting help on Google nothing worked

Took my phone today down to 2 EE shops, both were at a loss trying to sort it out and both said they had never come across this before

I never use any dodgy sites on my phone (or anywhere else) and no one else uses my phone except for me

Has anyone else ever come across this image before and know how to resolve it? Any feedback would be greatly appreciated



  • IMG_20220415_211041.jpg
    135.8 KB · Views: 17


Active Member
That error message is quite common in two circumstances:

Your Play Store is not up to date (you’ve prevented it from auto updating)

There’s a problem with the Play Store Cache

Make sure that system apps are allowed to auto update and that the phone itself is up to date.

Go into settings and clear the Play Store Cache

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom