Harmony Hub - When did things get this bad?

[email protected]

Well-known Member
My current Harmony Hub is coming up to 8 years old and has been great. Multiple changes of TV,s AV receivers etc etc have never been an issue plus I can even shout at it via my Google Home and make it do things.
But the companion remote is showing signs of use with many buttons now void of any icons. So much so my wife suggested perhaps it was time to replace it.
So I ordered a new Harmony Companion off Amazon with the thinking I might as well replace the hub and the remote at the same time and now I am wishing I never started.
So after spending an entire Sunday trying every option under the sun, I have given up.
I soon realised I needed to fully delete all previous hubs from the app before it would even connect.
I then discovered that even if you do this, you then need to uninstall the app and reinstall.
I then made the mistake of trying to copy the config off the old hub when asked. Back to square one, Delete all devices, the app and start again as the app no longer connects.
So I then set up the thing as a new hub. Set up the TV, receiver, STB etc etc etc and all is good to the point where you think everything is great. Hit the final OK button and the app goes into an endless loop of syncing and checking for changes which never ends so reset everything and start from the top.
I even got another iPhone and set it up as a brand new device. Nope
And then I went back to the old hub and I can no longer connect to that so had to forget it and rediscover the old hub. Thank god it remembered it's config.
Now I vaguely recall these things were always a right royal pain but at least they worked via the desktop app.
But Logitech no longer support MacOS and point you back to the iPhone app (which does not work) so defeated again.
So what gives? Are the new devices really this bad? Am I missing the obvious here?
And finally, is there any alternatives out there that do the same thing?
Google (and these forums) are full of speculation that Logitech is all for dropping Harmony any day now but there must be an alternative out there for those of us with multiple devices just wanting a simple life
 

Inked

Distinguished Member
No idea why you had to delete your old hub to add the new one, as you are able to run multiple hubs within the app and switch between them.

It’s certainly a pain that Logitech don’t support MacOS since the change to 64bit as it has removed some functionality from setup.

Unfortunately there isn’t much out there (certainly not at the price point) to replace the harmony remotes with.
 

[email protected]

Well-known Member
No idea why you had to delete your old hub to add the new one, as you are able to run multiple hubs within the app and switch between them.
indeed. There appears to be a huge difference between what it’s supposed to do and reality.

Yet the inconsistency in behaviour I have seen today has been at a level I haven’t experienced in consumer electronics in decades.

if I had bought this for my granny she would have stood no chance
 

Mevlock

Distinguished Member
Google (and these forums) are full of speculation that Logitech is all for dropping Harmony any day now but there must be an alternative out there for those of us with multiple devices just wanting a simple life
Absolutely dreading this.

My home cinema is all set up and working fine. But my Harmony hub and remote has centre place.

The very idea of having to switch to seperate remotes gives me nightmares!
 
Last edited:

dave77

Well-known Member
I would have just added the new Companion to the old hub, Harmony Upgrade > Add Remote. Maybe you can get logitech support to restore your account back to how it was previously?

You should be able to add multiple hubs though, I just bought a Companion myself to use in a seperate room to the existing Elite/Hub.
 

North2South

Novice Member
Just to add another viewpoint on using the Harmony Hub, I bought a Hub to use it with my mobile phone and therefore replace all of my remotes (4 remotes - DVD player, TV, Amp and Sky Q). All of the videos I looked at made this look easy and the hardware was all listed as supported by the Harmony Hub. However, I quickly discovered that my Audiolab 6000A was not switching input correctly between Activities.

After a lot of discussion with Logitech (to no effect) I carried out some analysis of my own to better understand what was happening. When I powered-off an Activity and then started a different Activity, the amplifier switched inputs to one that was 'two short' of the correct input. I couldn't understand why this was happening, but, by chance, I then switched Activity without powering-off the Activity and the switching of the amp was correct. I tried again and not powering-off, between switching Activities, ensured the Hub worked as expected! However, when I went back to powering-off and switched Activity, again the input selected by the Hub was two short of the required one.

So, it seems that using the App on a mobile phone means I have to remember which Activity was the last used by the Hub, so that when I power-up again the Amp's input remains the same and correct, then I can switch Activity and the correct input will be selected. My point is why do I have to remember the last used Activity, surely the App should do this and is this behaviour unique to my Audiolab 6000A?
The reason remains a mystery to me!

Since I wrote the above I have made another observation, which has solved the mystery of the incorrect switching. What I had not noticed was that the icon for each Activity is changed to an on/off power switch icon when the Activity is in use (how did I miss this and why is it not mentioned in their manual?), When I select this icon, instead of powering-off the Activity from the drop-down menu, the Activity closes completely and when I start another Activity the switching of inputs on the amplifier is correct - so all works well!
I re-read the manual and I can find no pointer to how to use the App correctly, through selection of the power on/off icon.
 
Last edited:

logiciel

Moderator
Powering off the Hub?
 

barnitto

Active Member
The Harmony experience is definitely not what it was. I have a stereo pre amp that wasn’t in the database (despite previous models being in the database) the remote wouldn’t learn the commands. Support did create a working command for me, but it won’t switch activities correctly, I have to power off before turning back on for a new activity. As there is a work around, support weren’t really willing to help further.

I am finding myself increasingly using various remotes,

As a Mac user, I’m dreading changing anything.
 

logiciel

Moderator
Yes, the activity, not the hub.
 

bobcar

Active Member
I only just realized today about Harmony remotes when I read this thread. I did immediately buy a couple of spares while I can, but this is awful news.
 

The latest video from AVForums

Oculus Quest 2 VR headset + Rotel A14 MkII Amp Reviews & Best of the Month
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom