Hard drive spinning when iMac asleep

The Grandfather

Active Member
Hi, As the title says I have a 2017 iMac 27" desktop with 1TB Fusion drive - bad choice should have paid for the 256Gb SSD version. In general I am really pleased with it and after years of Microsoft I am slowly seeing the light!! Mind you the learning curve has at time been vertical.
However I have one query that not even Youtube can answer. If I put the machine to Sleep rather than go to Shut Down the HHD can be heard to continue spinning long after any outstanding activity has completed. In fact it never stops spinning.

A Google search suggested that it could be a USB device that is causing the HDD to continuously spin. So all plugged in devices were removed. Plus I did a SMC reset and tried again.
Yippee the HDD span down and I thought - Cracked it. Oh no I checked about an hour later and it was spinning again!

My son on his Mac mini has no such problems as he is all SSD.

What next or rather what am I doing wrong? For interest the printer is off and anyway its wireless. The USB devices are DVD drive, Samsung T5 SSD backup and the external Time Machine HDD. (Its my old 2TB PC drive in a smart case with wall wart PSU.) I know that I don't really need the Samsung T5 SSD but its handy to take with me.

I don't think its a cooling fan that I can hear as the one time it did sleep properly there was not a sound to be heard.

Any ideas anyone? Its no big deal to shut down properly each time I use the machine but if I have to leave it I would like to my iMac sleep correctly until I come back to it. I know that modern HDDs are really good and long lived but seeing that opening up this machine is, for me, a big nono deal then I would like the HDD to spin down when not in use.

Thanks.

Nick.
 

The Grandfather

Active Member
All USB devices were in unmounted and physically disconnected. (DVD drive, Samsung T5 SSD and Time Machine). No power nap - its a desktop machine. However in the Energy Savings page in the Setup App I have set everything to optimise the computers chances of a ‘Quite Sleep’.

Please see second paragraph of my original post....Everything unmounted and disconnected.

Two days ago I spoke to the Apple help desk on a different matter and I asked them about this problem. They had nothing to add and no explanation!! They said it was ok for the HDD to spin.

From now on it’s a full shut down.
 

pcdunk

Active Member
I suppose you have wake for network access off and put hdd to sleep when possible on?
If you let the system go to sleep by itself does it still wake up?
Have you reset the PRAM as well as the SMC?
Have you tried turning off wireless and bluetooth?
You can try and find out what is waking the machine up by going into Terminal and running this command.

log show --style syslog | fgrep -i sleep | fgrep -v mDNS

It may give you some idea what is waking the machine up.
 

The Grandfather

Active Member
pcdunk,
Hi sorry for the delay in replying. For some reason Apple mail had decided to put your reply in the Junk. Heaven knows why as generally it has learnt that all things AV Forums are good.

Wireless and Bluetooth are not turned off as turning the Bluetooth off could mean that the Mouse and Keyboard would not work. The iMac is connected via Ethernet. PRAM has not been reset I'll have to find out about it - I'll even have to find out what it stands for!! LOL.

Thanks for the hint about Terminal and the command line. I'll have a play later.

Cheers. Nick
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom