H50B7500 Questions

tcoward

Novice Member
I've just got the H50B7500 and I'm wondering if anyone else has got one set up and could share the settings that work best for them?

I can't really tell if I like the picture or not at the moment - It's way better than my old TV, but it's different so will take some getting used too...
 

Dodgexander

Moderator
Its only been released for a few weeks so the chances of people owning it will be small. I'm hoping like with the A series AVF do a review because if its as good as last years model the provided you use the cinema/movie preset its picture accuracy out of the box was so good it would actually make matters worse tweaking or copying other peoples settings.
 

Obsgamer

Active Member
Its only been released for a few weeks so the chances of people owning it will be small. I'm hoping like with the A series AVF do a review because if its as good as last years model the provided you use the cinema/movie preset its picture accuracy out of the box was so good it would actually make matters worse tweaking or copying other peoples settings.
Yes it's a good TV but don't do an upgrade ota cos it stops the inbuilt apps working , unless they fixed it , have requested usb stick with latest fix from hisense but hasn't arrived yet
 

tcoward

Novice Member
Thanks for the replies. Cinema Day + Cinema Night seem to give good pictures, but there are some other settings I've had to turn off to get it looking right to me.
 

s4m77

Active Member
Yes it's a good TV but don't do an upgrade ota cos it stops the inbuilt apps working , unless they fixed it , have requested usb stick with latest fix from hisense but hasn't arrived yet
I received the USB from them today, however when I try and update it just says it already has the latest version. Have you got yours yet?
 

george1979

Active Member
Its only been released for a few weeks so the chances of people owning it will be small. I'm hoping like with the A series AVF do a review because if its as good as last years model the provided you use the cinema/movie preset its picture accuracy out of the box was so good it would actually make matters worse tweaking or copying other peoples settings.
I was hoping the same thing. This looks like a decent telly for the money. Considering getting this for my spare room but want to wait for some reviews as I've only found one so far and it wasn't that useful.
How have the guys who've bought it got on?
 

tcoward

Novice Member
I've had it a few days and I'm really impressed. It took a while to sort out some HDCP issues but it gives a really good picture and even HD content looks really nice. I haven't had the OS update issues that some others have had.
 

george1979

Active Member
I've had it a few days and I'm really impressed. It took a while to sort out some HDCP issues but it gives a really good picture and even HD content looks really nice. I haven't had the OS update issues that some others have had.
Thanks, have you used it for gaming at all? I'd primarily use it for my xbox and PS4 but I was holding off for a review of the gaming mode input lag. The fact it has dolby vision is a real bonus at the price. Also noticed on other threads someone said the OS menus were slow? Not a major issue given it'll be used for gaming mostly but just curious.
 

Obsgamer

Active Member
I received the USB from them today, however when I try and update it just says it already has the latest version. Have you got yours yet?
Yes got ours today and same issue as you it's an older version , rang hisense and they say it's common fault and ota update will be out end of August
 

tcoward

Novice Member
Thanks, have you used it for gaming at all? I'd primarily use it for my xbox and PS4 but I was holding off for a review of the gaming mode input lag. The fact it has dolby vision is a real bonus at the price. Also noticed on other threads someone said the OS menus were slow? Not a major issue given it'll be used for gaming mostly but just curious.

Yeah I've played some xbox on it. I haven't noticed any lag, but I don't tend to notice things like that. It has a game mode that is supposed to reduce any lag. Menus seem fine to me.
 

Lucyb17

Novice Member
Finally found other people with the b750p. I have the 65 inch model and I got it yesterday.

I downloaded the update (stupidly) and now I can't access apps. so last night i couldmt do anything on it.I hope a factory reset will work or I'll have to get a usb too.
My biggest gripe is the motion.

I watch anime on Netflix and whenever there's a tiny bit of movement it goes pixelly and like it's missing frames .it looks god awful and makes me want to return it . I thought to turn up motion smoothing up to get it to work but it didn't. Going to try turn it off when I'm home tonight. Anyone else have this problem?
Also it does this on YouTube videos but I can't change the motion on it
 

lpoolm

Active Member
Finally found other people with the b750p. I have the 65 inch model and I got it yesterday.

I downloaded the update (stupidly) and now I can't access apps. so last night i couldmt do anything on it.I hope a factory reset will work or I'll have to get a usb too.
My biggest gripe is the motion.

I watch anime on Netflix and whenever there's a tiny bit of movement it goes pixelly and like it's missing frames .it looks god awful and makes me want to return it . I thought to turn up motion smoothing up to get it to work but it didn't. Going to try turn it off when I'm home tonight. Anyone else have this problem?
Also it does this on YouTube videos but I can't change the motion on it
I got the 55" yesterday, watch the football on it and it looked fine.
Today however I watched jurassic park 4k, colours look pale and felt some bits looked a bit grainy, (i know its an old film) but some fast bits like you say seems to skip a bit?
I ended up turning the ultra smooth motion off and think it may have stopped? but kids were moaning so had to stop my testing.
I have not opened the instructions yet... but have noticed I make changes to the settings but they dont seem to save? so switched from watching jurassic park now to a sky recording and the settings are back to standard?
I need to have a read up but feedback with how you are getting on
 

JasTheBald

Novice Member
I took delivery of a 50B7500UK on Monday, was sadly disappointed.

The picture quality out wasn't the best, I found it struggling with motion at times and pixelating across the top of the screen, even in HD/Streaming.
The SD picture through the built in Freeview was quite bad. Everything seemed to be in soft focus and blocky where small detail existed

I spent quite a while with it on Monday night trying different picture modes and adjusting the settings within them, including switching on/off all picture enhancing settings in all variations.

HDR for gaming seemed a bit dark/foggy too.

I bought it to replace a 3 year old LG of the same price point, and the LG is still a much sharper screen (despite it being faulty).

It's going back to RS on Saturday, I'm exchanging it for another LG, it might fail but the 6 year warranty helps.
 

MrClive

Active Member
I've just had a 55B7500 delivered a couple of days ago.
Early days but so far the picture looks good. Using Cinema day.

I did have to switch Ultra smooth motion off. Weirdly live action was fine for me, I noticed glitches on the simpsons (which my kids watch lots of) so had to switch it off. In fairness I haven't noticed a difference with it switched off. Does anyone know what it's meant to do?

I also has problems with Lip sync being with the sound bar using the optical port (particularly on Prime). I did mess around with the settings (lip sync), then opted for an ARC connection which now seems to be working OK.

Which version of the software works best? I think my version is V0000.01.00A.J0710

Any tips on other settings?

***correction the lip sync issue is still present when using the arc connector, but when using the prime app on the TV. Prime app via the virgin box is fine**** has anyone come across this issue***?
 
Last edited:

MrClive

Active Member
Finally found other people with the b750p. I have the 65 inch model and I got it yesterday.

I downloaded the update (stupidly) and now I can't access apps. so last night i couldmt do anything on it.I hope a factory reset will work or I'll have to get a usb too.
My biggest gripe is the motion.

I watch anime on Netflix and whenever there's a tiny bit of movement it goes pixelly and like it's missing frames .it looks god awful and makes me want to return it . I thought to turn up motion smoothing up to get it to work but it didn't. Going to try turn it off when I'm home tonight. Anyone else have this problem?
Also it does this on YouTube videos but I can't change the motion on it
Are you still having the motion issues?
 

TheGiggler1991

Novice Member
I have lost all my Freeview Play channel's.

On software version V0000.01.00A.J0710

Does anyone know if there's an upgrade available, it's really annoying
 

MrClive

Active Member
I was given J0725 last week by Hisense. I’m not sure about free view channels as I don’t use them on this TV.
 

MrClive

Active Member
I rang in and they logged a ticket. I can send you the link to the software down load update, but it might not be the fix for you
 

TheGamer147

Active Member
What it called when the picture moves fast and you can still see the trail from where it was is it called ghosting? I get that alot on Netflix
 

Gary65

Active Member
I have the 50 inch and see none of this on apps or virgin v6 box ,the only slight criticism is uniformity on all white background dark in places but in normal tv viewing including football all good and pleased for £399
 

Similar threads

Trending threads

Latest news

Elipson launches new Planet W35 speaker
  • By Andy Bassett
  • Published
AVForums Podcast: 11th November 2019
  • By Phil Hinton
  • Published
BBC and Sky agree new collaboration
  • By Andy Bassett
  • Published
Klipsch releases S1 True Wireless earphones
  • By Andy Bassett
  • Published
Rotel to re-launch Michi components in UK
  • By Andy Bassett
  • Published
Top Bottom