Question Grounding issues on turntable - but only in the mornings!

Discussion in 'Hi-Fi Stereo Systems & Separates' started by pigeonchest, Jun 22, 2016.

  1. pigeonchest

    pigeonchest
    Novice Member

    Joined:
    Jun 22, 2016
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    4
    Location:
    Malta
    Ratings:
    +0
    Dear all, this is my first post so hello everyone.

    I have a grounding issue on my setup. I have a Pro-Ject Carbon and an Audio Analogue Primo Settanta amplifier - that's the only thing I have connected. Everything worked fine for a few years, but lately I am hearing a ground noise (like a whistle) as soon as I turn the amp on and select the phono input. Turning the volume up also turns the noise up. I checked all the cables and everything seems fine. The only thing I've been able to detect is that, by touching one specific cartridge connector on the tonearm with a mains tester, the noise goes down substantially. I made sure they're well inserted and everything looks fine.

    Now the weird part. This only happens in the mornings, up until about 4/5pm. After that time everything works fine, everyday. I suspect there's some sort of machinery in my block that goes off at that time, but I have no idea what it could be.

    Thanks for your help!
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice