Green Screen with Cambridge Audio DVD55

Discussion in 'Blu-ray & DVD Players & Recorders' started by Waser, Jun 28, 2004.

  1. Waser

    Waser
    Active Member

    Joined:
    Mar 1, 2004
    Messages:
    1,043
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Purley, Surrey
    Ratings:
    +75
    I am having some problems with the scart RGB output on my new Cambridge Audio DVD55. Whenever I select RGB output the image goes green. I am feeding it into a Panny TX32LXD1 and tried both scart inputs to see it wasn't the TV (I have sky and games consoles attached with RGB connections and they work fine) so it seems to be a problem with my DVD player.

    I intend on connecting the player with Component leads soon anyway but I was wondering if anyone had a solution to this problem?

    :lease:
     
  2. Ed Selley

    Ed Selley
    AVF Reviewer

    Joined:
    Jun 26, 2003
    Messages:
    11,200
    Products Owned:
    1
    Products Wanted:
    2
    Trophy Points:
    166
    Ratings:
    +3,674
    Heard of- yes, solution- no

    Some TV's seem to respond very badly to the Cambridge RGB setting. Their engineering Panasonic is fine but our Loewe Mimo goes fairly green when switched to RGB with a 540D. I am afraid I have no idea why, my JVC is unaffected so I've never really pushed it.
     
  3. Waser

    Waser
    Active Member

    Joined:
    Mar 1, 2004
    Messages:
    1,043
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Purley, Surrey
    Ratings:
    +75
    :thumbsdow Not good...

    I am probably gonna return it anyway. Not too satisfied.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice