GPU/Mouse noise from USB DAC

michtyme

Active Member
I’ve recently switched from using my G6 as an all in one to using the G6 as a DAC fed by an RCA cable into the Schiit Asgard 3.

Unfortunately I seem to be getting audible noise from the G6 such as mouse movements and GPU noise.

If I feed the G6 from a different wall outlet and use optical out from the PC, The noise isn’t audible any longer but doing so makes me lose the mic and other functions of the G6 obviously which I would like to keep for gaming.

Similarly, Just using a different wall outlet but leaving the RCA connection in, The noise also disappears so its pretty obvious the G6 is passing on noise to the Asgard via the DAC output.

I've just bought the iFi idefender+ in the hope that fixes it. Has anyone tried one?
 

Steven

Senior Moderator
Try different things. Many (many) years ago a Graham slee amp had hum through the headphones that disappeared when I plugged in a belkin surge protector with very basic filtering ☺️
 

michtyme

Active Member
Try different things. Many (many) years ago a Graham slee amp had hum through the headphones that disappeared when I plugged in a belkin surge protector with very basic filtering ☺️
Hi Steven!
Thanks for the suggestion!
So far I've tried:
Powering the amp from a different socket
Changing USB ports
Changing settings on the PC
Changed to optical out from PC (this worked)
Leaving RCA connected between the two and swapping to a different USB source (this also worked)
I'm pretty certain it's to do with the USB connection from the PC to the DAC.
 

The latest video from AVForums

Movies Podcast: Star Trek in 4K. Is the new boxset worth it?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom