Goodmans GTV42P3 Plasma Problem - Help!

Discussion in 'Plasma TVs Forum' started by rollwrong, Aug 6, 2006.

  1. rollwrong

    rollwrong
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I've looked through the FAQs and browsed the forums but can't see anything similar to this posted...

    Had my Goodmans GTV42P3 for about 18 months and had no problems with it whatsoever, until this morning...

    From any source, all that is displayed is a screen full of multi coloured static that seems to respons to changing channels etc, so it seems that the panel itself is ok, just that its not receving a properly decoded signal (or something completely different, I'm no expert here).

    Tried PC VGA feed and that gives similar results. When you power it on, you get a couple of lines of static at the top and bottom with a totally blue (normal) screen followed by the screenfull of rubbish I described above.

    Its out of warranty, any ideas?

    Many thanks!
     
  2. bonzobanana

    bonzobanana
    Well-known Member

    Joined:
    Aug 21, 2001
    Messages:
    3,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Yeovil
    Ratings:
    +220
    A friend had a similar problem with a techwood from currys which I believe is similar to the Goodmans (looks very similar anyway) and in the end Currys replaced it with a 40" Samsung LCD which my friend was over the moon with. Much better set even if he lost 2 inches of screen. I would guess that if the fault is in the panel itself its unrepairable but if its in the external tuner/scart box then its repairable. Alternatively if you have house insurance you could wait for a lightning/thunderstorm......
     

Share This Page

Loading...