• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

God I need some help with this!!!

M

memece3

Guest
I have a s750 gigaworks, ddts-100 and Denon 887 and for the life of me I cannot get these to work together.

I have the speakers hooked into the ddts-100, then have an optical running from the ddts-100 opt-1 to the Denon Opt-3 out.
The Denon has 4 opticals. 3 under in and then it says 3 out which would # 4.
That is where I have the opt runinng from the ddts. Now creative says that is how it should be hooked up but I can't get any sound at all from anything.
Gone through all the menus in the Denon, still nothing. Anyone have any ideas? Creative says it should work, but I don't see an option in the Denon for Optical output just inputs. You have Speaker A, B or Zone 2.
Any help would be appreciated!

Thanks

Matthew
 

Knyght_byte

Distinguished Member
optical outputs are normally stereo only when on a receiver/amp.....only players usually have 5.1 outputs....that might be causing problems...

also check whether its set to PCM or Bitstream etc....

i'm not familiar with the 887 tho so i wouldnt like to say...
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom