Quantcast

Getting Tracks in order using I-Tunes

Rendini

Standard Member
I am new to all this, have searched the forum here but can't see this anywhere.

My Issue is, having imported albums into I Tunes it does not store the track number and thus puts them in alphabetical order rather than album track order. This is despite the fact that say the Coldplay album shows track numbers in each songs filename.

Is this any way other than manually editing "get info" to fix this. I have tried the get CD track names but it just says re-import files again.

Your help much appreciated.
 

Chris_J_0907

Novice Member
Go into the view options and check the track number option. There should be quite a few to show there.

Once you've done this, you can click on track no. at the top of the playlist/library and it should do it for you. HTH.
 

Lester

Active Member
If you click on the column "Artist" or "Album" header in iTunes then it will sort in ascending or descending order....thus displaying the tracks in the correct sequence (or opposite thereof).
 

Rendini

Standard Member
I not sure I have explained myself properly. Having imported the tracks there are no track numbers to show (i.e the track number view is blank). Thus clicking album or artist just puts them in alphabetical ascending or descending order.

Here what I did, I have Coldplay XY album stored on my C: (not Itunes directory) in mp3 format track one is labelled 01_square_one, track two 02_what_if etc..
I then in I-tunes use "add folder to my library" once it has done the album is loaded into I Tunes.

However no track numbers are displayed in the track number view, filename sin I-Tunes directory have removed the number i.e 01_square_one is now square one. End result is tracked are displayed in alphabetical order.

If I then ask i-tunes to get cd track names it just says "I tunes cannot get track names for songs that we not imported using I tunes" Weird even though I just did.

Only way I can see around this is to click get info and manually enter track numbers this will take ages though.

What am I doing wrong as this is surely not the way it works.
 

Lester

Active Member
I'm afraid this is the way iTunes works. It will only automatically attach track numbers when importing from the actual CD.

You should be able to find the track numbers for already imported albums by using third party software. I don't know much about these, but a friend has used Fixtunes and reports moderate success. I think it costs $20. There may be free or better ones about that others can recommend.
 
S

shadowritten

Guest
Rendini said:
I not sure I have explained myself properly. Having imported the tracks there are no track numbers to show (i.e the track number view is blank). Thus clicking album or artist just puts them in alphabetical ascending or descending order.

Here what I did, I have Coldplay XY album stored on my C: (not Itunes directory) in mp3 format track one is labelled 01_square_one, track two 02_what_if etc..
I then in I-tunes use "add folder to my library" once it has done the album is loaded into I Tunes.

However no track numbers are displayed in the track number view, filename sin I-Tunes directory have removed the number i.e 01_square_one is now square one. End result is tracked are displayed in alphabetical order.

If I then ask i-tunes to get cd track names it just says "I tunes cannot get track names for songs that we not imported using I tunes" Weird even though I just did.

Only way I can see around this is to click get info and manually enter track numbers this will take ages though.

What am I doing wrong as this is surely not the way it works.
Whilst I don't know how to fix your specific problem in iTunes, I can tell you this: filenames are completely different from track tags, which is what iTunes and other music management programs display.

You need a tagging program (I use eMusic Tag Editor from Abyss Audio, although free software is available if you search for it). This will help you ensure that ALL track tags - artist, album, track number, genre, etc - are correct before you import your MP3s into iTunes or other similar programs. This will solve your basic problems.
 

HMHB

Distinguished Member
Unfortunately with iTunes you do need to make sure that you've set things up properly in the Preferences before you do any importing. So if you set all the import options (including importing the track number) then it will do it for all CDs you import. If you haven't imported many CDs it may be easier to delete everything from iTunes and import again with the Preferences set correctly.
 

Rendini

Standard Member
Sounds like I need to start again I have only done a few MP3's I have downloaded and a couple of CD's. Oddly one or two albums work fine but other don't.

What in preferences do I need to change as on the importing tab there is nothing about importing tracks.

Have to say I have heard great things about I-Tunes but so far I am not impressed!
 

Rendini

Standard Member
Thanks JohnG I must be blind! checked and it was already ticked.

Deleted all my file and songs in I-tunes tried importing an album off my hard drive but same problem no track numbers stored. Does this only work when importing from a cd?

Looks like I may have to use an editing programme suggested above for any downloaded music.

Surely I must be in the same boat as everyone else here or do most people not care what order it plays an album in. Makes downloading Mp3s very unattractive.

Can anyone sugggest a good freeware program that I can use to get my tracks sorted before importing to I-tunes.
 
M

mick's cat

Guest
Rendini said:
Sounds like I need to start again I have only done a few MP3's I have downloaded and a couple of CD's. Oddly one or two albums work fine but other don't.
Make sure you're connected to the internet before you insert CDs, as iTunes links to an internet CD database (Gracenote) to get tag information.

Rendini said:
Have to say I have heard great things about I-Tunes but so far I am not impressed!
Stick with it, as it really is a good app. Very powerful under the bonnet, but that also makes it easy to miss out on the good stuff.
 
Top Bottom