Genserve collected 606, delivered 875

DaveHope

Novice Member
Hi All,

GenServe collected my TX-SR606 on Friday for a warranty repair (low frequency noise when Audessy was enabled, reduced noise when Audessy was disabled). I was quite surprised when CityLink collected my 606 only to give me another box in exchange.

Having opened the box, inside was a TX-SR875 with a repair note describing a similar problem to mine (citing loose PCBs and a replaced fuse as the cause). All details on the repair note etc were mine.

Is this the norm? - Do Genserve usually replace the item? (even temporarily until it's fixed). I was under the impression i was going to be without an Amp until mine was fixed.
 

namuk

Distinguished Member
Thats a new one :D i would Phone though to see what happened , bet they just did a swap out .
 

DaveHope

Novice Member
The 875 is certainly a step up from the 606 (THX certification for one), searching around on here I can't see that they've given out temporary units before. Furthermore, It seems unlikely for them to give you a temporary unit better than what I had.

The date of purchase on the Genserve receipt is what I estimated to them over the phone, as is the original retailer. Perhaps they have just swapped it out? I find it quite unusual for them to have done that without agreeing it first (not that I mind :) ).

I'll give them a call on Monday to find out, I'd hate for a member here to have lost their Amp because Genserve sent it to me instead!
 

Daz1969

Active Member
lucky bugger :thumbsup::thumbsup: if i send you my 577 with a note inside will you send me that 875 :D:lease::hiya:
 

DaveHope

Novice Member
I'm clearly too honnest :) Just called Genserve and they've said it's definately a mistake on their part, for some reason they had a repair of an 875B booked in my name.

They've found out who the 875 belongs to (it's a company based in Essex), but are letting me keep hold of it until my 606 is repaired :smashin:
 

namuk

Distinguished Member
I'm clearly too honnest :) Just called Genserve and they've said it's definately a mistake on their part, for some reason they had a repair of an 875B booked in my name.

They've found out who the 875 belongs to (it's a company based in Essex), but are letting me keep hold of it until my 606 is repaired :smashin:
Best way being truthful :smashin:

Do not go in 875 thread just in case there is a member that has sent his away and awaiting return :rotfl:
 

DaveHope

Novice Member
Do not go in 875 thread just in case there is a member that has sent his away and awaiting return :rotfl:
hah :) The owner of the 875B is an AV retailer, so they'll probably not be on here. If anything at least I'm likely to get a quick turnaround from Genserve.
 

IAIN-50

Standard Member
Hi below is my email & reply from Genserve

Hello I have a problem with my 507 AV Amp.

Purchased in November 2009 about 2 weeks ago it stopped being able to record from Virgin V+ to Sony HDX995 via HDMI.

Took it back to supplier who said that it would have to be sent away

Being a member of AV Forums I have found posts that say Genserve picked up their faulty unit & supplied a loan unit, is this the case.

I look forward to your reply

Regards Iain


Hi Iain

Yes we arrange a courier to collect from you it needs to be in a box.We don't leave loan sets unfortunately the turn around time is 5-10 days.You will need to call us so that we can arrange a collection time with you.​

Regards
Cath
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom