Games on external SSD won't update

silvercue

Distinguished Member
I recently got an external SSD, one recommended for PS5 use, and installed PS4 games on it. They all work fine.

Except auto updates all fail and the only solution I can find is deleting the game and re-installing. This is a massive hassle for games like Apex, Warzone etc as they are so big.

Wondering if it is related to moving the game rather than installing them there in the first place...

I see this is widely reported. Anyone here got this issue and found fix/workaround?
 

duffbeerdrinker

Distinguished Member
I noticed the same thing for games that I moved from internal to external storage. Seems to update fine if you install the game directly on to the external.
 

Ultrasonic

Well-known Member
Except auto updates all fail and the only solution I can find is deleting the game and re-installing.

So manual updates fail too?
 

rb5201

Well-known Member
I've had this with two games I've put on an external hard drive. Just comes up with an error message.

Haven't tried yet but was hoping if I move game back to ssd this might allow it to update, and then move back to external. Bit if a pain if this is the only way, plus of course got to have the spare space on the internal!
 

Wing80surfer

Active Member
I'll check mine a bit later. Not ideal but rather than uninstall/reinstall, could you move the game back to internal drive to update & then copy back to external?
 

BigAardvaark

Active Member
Move to internal, update, move back, works. But only once - unless they've fixed it with newer firmware - come the next update, you're back to square one.

Completely delete it, redownload and install to external does fix it for good. Although not ideal if you've haven't got fast internet....
 

JonJ

Active Member
Mine seems OK - but it does seem SSD related. My last Samsung T7 500TB SSD refused to update when in rest mode for PS4 games and I gave up and only did it by leaving PS5 on.

I recently swapped for a T5 1Gb SSD and that works just fine (both before and after the latest firmware). Sometimes it shows as an update stuck at 100% but launching the game in question seems to fix it.

I've also notice the update issue on moved games, but on mine it was only a couple that refused to work - Hitman being one. Had to reinstall. But other games have been fine, after moving and also in rest mode.
 

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom