• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Fusion FVRT145 after switchover?

Mad-Mac

Standard Member
Hi, my trusted Fusion FVRT145 has lost all channels since the switchover down here in Torbay and I'm stumped.

My aerial signal says it has 100% errors on both tuners (was absolutely fine before the final switchover) and a complete reset and format still hasn't helped to cure the problem.

I've tried a different aerial in a different position, but no joy!

Is there anything else I can try - or is it now fit for the dustbin only?

Thanks in advance. :lease:
 

Starburst

Distinguished Member
Welcome:)


It may be related to the change in broadcast specification which some older boxes are not capable of supporting.

More info here.
 

Mad-Mac

Standard Member
Yeah, I had already thought of that, but downloaded the list earlier and my Fusion isn't on there? As the company is no more I'm a bit stumped. Spent all afternoon searching online for a solution, but nothing so far.

As I can't change MUX or transmitter info on it, I suppose I'm left with a bit of junk!
 

Starburst

Distinguished Member
A google did find others saying they were having issues post DSO with boxes that have been accredited with the digitaluk tick.
 
Last edited:

Starburst

Distinguished Member
Good, always nice not to have to spend money:)
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom