Frustrating mic problem.


Distinguished Member
My Daughter had a new gaming PC for Christmas (homebuilt by me) and I have a problem getting the mic to work on her headset.

The headset is a USB Razor Kraken Kitty and it works fine if I plug it into her old PC. I get sound through the headset speakers and the Razor software detects if I switch the mic on and off on the physical switch on the headset. I have the headset set to be the default audio device under Windows for both speakers and mic and I have disabled all the other devices listed under mic (ie the on board souncard stuff). Input volumes are all set up, mic is enabled in Windows and I have done a clean re-install of the Razor software. If I run the mic test under the Razer software or Discord I get nothing.

Any ideas?


Distinguished Member
I'd re-enable the other devices, that's not the sort of thing you want to leave disabled or it might come back to haunt you in future.

I don't currently have a microphone connected to this PC but from what I remember Windows does have a seperate volume control for input devices so it's worth checking that's turned up and unmuted. Might be worth having a look at volume mixer too.


Well-known Member


Distinguished Member
Thanks both. I managed to sort it in the end. The MOBO and SSD came from a doner PC, an HP Omen branded machine and the SSD had the default image for that machine on the drive. I noticed that there was HP's own audio control panel running in parallel with the Windows audio controls and the Razer software. I got rid of the HP panel (Along with the rest of their bloatware) and after a reboot it worked fine. I guess something was conflicting there.

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom