From AVR no projector signal but TV signal ok

AtulV

Novice Member
Hi, recently I bought Denon AVR X2700H and Epson Projector EH-TW 9400. I get proper picture signal on my Sony TV but when I connect projector, I get No Signal on the screen. I tried changing the hdmi cable, but no success. When I connect firestick directly to projector HDMI rear connector, I get proper picture. I hope HDMI output of the brand new AVR is not faulty. Can anyone suggest a solution, please.
 

Luminated67

Distinguished Member
Hi, recently I bought Denon AVR X2700H and Epson Projector EH-TW 9400. I get proper picture signal on my Sony TV but when I connect projector, I get No Signal on the screen. I tried changing the hdmi cable, but no success. When I connect firestick directly to projector HDMI rear connector, I get proper picture. I hope HDMI output of the brand new AVR is not faulty. Can anyone suggest a solution, please.

What length is your HDMI cable from the AVR to the projector and is your HDMI cable an optical one, you will know if it’s optical because on the ends one will say source and the display.

This is how your cable ends should look with the wording so you know which end goes where.

22042062-6C48-40A8-AACA-3854B0B7ABF9.jpeg


I’m 99% certain it’s your cable.
 

AtulV

Novice Member
Thanks. My cable length is about 30-33 feet. Earlier I was using Epson TW-EH 8200 (and marantz SR 7008) projector and with the same cables (1 in use 1 spare) it worked fine for 3 years then it stopped, unrepairable. Today I got a 45 feet Bluerigger HDMI expensive cable, connected it temporarily but didn't work.
 

Luminated67

Distinguished Member
Thanks. My cable length is about 30-33 feet. Earlier I was using Epson TW-EH 8200 (and marantz SR 7008) projector and with the same cables (1 in use 1 spare) it worked fine for 3 years then it stopped, unrepairable. Today I got a 45 feet Bluerigger HDMI expensive cable, connected it temporarily but didn't work.
Originally when I built my room 4-5 years ago I got the electrician to run a 10m QED Reference cable at well over £100 at the time but when I switched to the Epson I couldn’t get a signal from my new Sony X700 BR player because it was wanting to output 4K. Unfortunately price doesn’t mean it will work when you increase resolution.
Has it anything to do with resolution?
It has EVERYTHING to do with resolution, if you are trying to feed a 4K HDR 60Hz signal through a cable that at that length might only be capable of 1080P then the end result is no signal and blank screen.

ATZEBE HDMI Cable 10M, Fibre Optic HDMI Cable High Speed 18Gbps HDMI 2.0 Support [email protected] HDR10, 4:4:4, 3D, ARC, HEC, CEC, HDCP 2.2 Amazon product
Less than £50 and will sort your problem, plus if you discover it doesn’t and it’s something else you have Amazon’s return refund policy to fall back on.
 

AtulV

Novice Member
Thanks for your prompt responses. I will try to downgrade the resolution to 1080 and see if the cable works. If not, I shall buy the ATZEBE cable and see. Thanks again. Hope you and your family are in good health.
 

Luminated67

Distinguished Member
Thanks for your prompt responses. I will try to downgrade the resolution to 1080 and see if the cable works. If not, I shall buy the ATZEBE cable and see. Thanks again. Hope you and your family are in good health.
You should only need to set the resolution on the Denon to 1080P and see it that gets you a signal, if it does then you know for sure the cable is the issue.

The problem with rating on the likes of Amazon etc is that they include all lengths so when you see a 4-5 star rating you think all good but through experience with myself, this forum and over on AVS the cable beyond 5 meters is best switched to an optical one, not that some regular cables won’t work a bit longer than this but why take the chance when you know for sure optical does the business.
 

Marky1973

Well-known Member
I can second the Atzebe cable...got one for my 9400 and it seems to be working a treat!
 

AtulV

Novice Member
Thanks. I tried downgrading the video resolution in the Denon AVR x2700h to 1080P but still projector 9400 display "no signal. So I think I have to buy the Fibre optic HDMI cable. Here in India, on Amazon we don't get ATZEBE cable but other makes are available. Unfortunately, due to covid lockdown, Amazon doesn't deliver as it doesn't fall under "essential items". I may have to wait till situation becomes normal.
 

AtulV

Novice Member
Update: I tried all the Cu and Fibre optic HDMI cables but the "no signal" problem continued. After several trials of elimination, I have found that the Denon AVR X2700H is defective....I have lodged the complaint but unfortunately due to Covid lockdown, it shall be attended only after 15 days....
Thanks everyone for suggestions.
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom