Freeview Play Help not working HZ2000


Active Member
Hi Guys, Tonight I decided to use the freeview play feature on my new Panasonic hz2000 OLED TV for only the second time and now it doesn't work.
None of the Freeview ch's are working, just stuck on a screen saying loading. Other online apps like Prime, netflix and youtube all work fine.
Tried the Roku enabled tv in the bedroom and all on demand freeview play working fine so it's not the service.
I powered off Main TV for 5 mins and tried again but no luck. Any help to get this resolved would be most helpful, thanks in advance.


Standard Member
If it's like my 980b this is a known issue. Turning your TV off and on his the switch should get you up and running

Edit: replied before fully reading your post


Active Member
ANYBODY?? Still no joy with this freeview play problem, I called Panasonic today and GET THIS -the guy told me that my freeview play needs to have my sky box connected for it to download, SERIOUSLY??
I don't really want to do a complete system reset as he suggested in the end, as I have all the picture modes calibrated plus all the hassle of re-signing into and verifying all my apps about 9 at least.
Had this TV for less than 3 months and already I got all this hassle, my cheapo system in the bedroom with Roku works flawlessly every time with catch up so why cant this NEW tv?


Well-known Member
I was going to suggest resetting the network connection but if other apps work fine, then that obviously isn't the cause. You could try turning off your TV (via the rear switch or by unplugging) for longer than 5 mins - I forget the recommended amount of time for this, but some internal components retain their charge for longer than that, I believe.

I had problems getting iPlayer to work initially on my GZ and it turned out to be a privacy settings issue. Check your setting by going to Setup - Data Service Application - Privacy Setting. I think I had mine (instinctively) set to 'High' which caused problems - setting it to 'Low' fixed the iPlayer issue and the catch-up apps and Freeview Play all work fine.

If that doesn't help, then I can't see any way of avoiding a factory reset. It's the first thing any manufacturer or retailer is going to want you to do in the event of a problem like this. If it makes you feel any better, I did a factory reset after 4 months in an attempt to fix a sluggish UI and it turned out to be flat batteries in the remote :D


Active Member
Thank you so much mikej, that did the trick, my setting was on custom (can't remember setting this) I set to minimum and now all services working fine. One would have thought Panasonic Customer support would have known this.
I should have just hung up the phone after the guy suggested to me that my Sky box needed to be plugged in and updated to receive the downloads for freeview play to work (I don't even have Sky) instead I wasted 45 mins with him in the end telling me to do a complete reset -really? I need an expert to tell me that? Always worth coming here first, so many knowledgeable people on here.


Active Member
ps, I'll remember to check my batteries if I get the sluggish UI thing see, more helpful info Lol.

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom