Freesat 4k tv box

LiamG2000

Novice Member
I have a freesat 4k tv box and everytime I turn it on there's no picture and I have to keep resetting the box to get a picture
Can anyone help?
 

Rodders53

Distinguished Member
hdmi handshake issues most likely

1) try different hdmi lead(s)
2) try different hdmi input on TV

but also try switching TV to another input (TV tuner, alternative av input) and back to the freesat box to force a new handshake. (Rather than removing power from the box).

If the TV is UHD, and as there are no 4k broadcasts set the box to 1080i (or 1080p) rather than UHD with forced HDR? That may help. {Only change to UHD if you must use the box for streaming 4k stuff}
 

LiamG2000

Novice Member
hdmi handshake issues most likely

1) try different hdmi lead(s)
2) try different hdmi input on TV

but also try switching TV to another input (TV tuner, alternative av input) and back to the freesat box to force a new handshake. (Rather than removing power from the box).

If the TV is UHD, and as there are no 4k broadcasts set the box to 1080i (or 1080p) rather than UHD with forced HDR? That may help. {Only change to UHD if you must use the box for streaming 4k stuff}
Do I try changing the hdmi lead from hdmi2 to hdmi1
 

Rodders53

Distinguished Member
AIUI V1 is fine for HD 1080i as all broadcast channels are transmitted. V1.4 can do UHD at 30 fps so why not try it?

Do also check the supplied hdmi cable is seated properly in both box and TV set.

Do try the < force hdmi handshake > by switching TV inputs and back first - after checking the cable's seated properly.
 

LiamG2000

Novice Member
AIUI V1 is fine for HD 1080i as all broadcast channels are transmitted. V1.4 can do UHD at 30 fps so why not try it?

Do also check the supplied hdmi cable is seated properly in both box and TV set.

Do try the < force hdmi handshake > by switching TV inputs and back first - after checking the cable's seated properly.
What V1.4
 

LiamG2000

Novice Member
Seems you've already done that hdmi input swap! ;)

Any improvement?

Also try another hdmi lead between the two units...
I, mistakenly, assumed freesat provided a Version 2.0 cable and you had a Version 1.x to use instead... ;)
That's worked thanks
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom