Freeagent Theater+ owners... Help pls

penyekz

Standard Member
Hi, Just got the FAT+ for a few days now and I've experienced an annoying bug!



After docking in the Freeagent Go drive and turning on the device, the freeagent go drive doesn't load up automatically. I have had to cycle the power off-on again before the freeagent go drive shows up on screen. This can also occur after the device has been switched off for an extended period of time as well. Each time, switching the device off and on again solves it. Is this an annoying bug thats in all systems or just is it a hardware issue?



Also, the device runs very very hot especially after a movie. Can fry an egg on it! Is this normal?


I am using the latest firmware 1.27 loaded using USB thumbdrive.




I was debating between the freeagent theater+ or the AC Ryan Playon. Maybe I should have gone for the latter..... :(
 

next010

Distinguished Member
The Freeagent+ and playon are actually the same Realtek hardware.

Your unit doesn't sound like its working properly but I've never owned one, I think the best thing to do would be to contact Seagate directly and see what they say about it.
 

penyekz

Standard Member
Thanks for replying. The Playon has got a great user interface compared to the Seagate's. Apart from that, the firmware difference means that playon has more features such as Bittorrent client built in and being able to use the media player as a NAS.

Anyway, I've tried formatting the drive but it still doesn't resolve the issue. I'm gonna try to exchange the device this weekend.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom