FREE Oppo and Clones Jailbreak

baboba

Standard Member
Thanks for your information. That explains, why the identical configuration works on the M9702 and not on the M9201.
You can try the Android/iOS Oppo MediaControl App to see if you can initate a safer power OFF command?
Didn't find any option in the app to change the Power OFF command...

I'll wait if there comes a better solution in the firmware. Until then, I'll be going back to AutoScript - at least that works.

Hey theaxledentaldj - you are a very friendly and helpful person - thank you very much for your help!!
 

Dersimli

Active Member
Hello friends I have 2 problems

1-I couldnt back up NAND. I downloaded the script, put it to USB (Fat 32) but When I enter oppo I cant see it in oppo. How Can I make it work?

2- I have an oppo 205 Europen. Does this activated RU firmware work for also 205? What must I do it work for 205?

Sorry for my English
 

theaxledentaldj

Active Member
Dersimil, did you read page 1 post 1 about how to backup your NAND? It should have written 23 files to the Flash drive. The Oppo-203/205 doesnt like all USB Flash drives.Try another one

The RU JB Firmware works on an Oppo-205.
 

ChristianMSchneider

Novice Member
At first I thought th Superdisc patches only the discplayer, but since the regionfree was removed with my firmware up/downgrade I think is must be something in the NAND. This is why I suggest a NAND backup before and after.
Hi Thomas,

thank you very much for your hint to the Superdisc.

I have copied oppo_superdisc.iso from the website you referred to an USB stick but the Oppo did not like that, I got the message "Unknown (or invalid) file format".

I then burned oppo_superdisc.iso onto a DVD with the Imageburn software SetupImgBurn_2.5.8.0.exe (all default settings) and put that disc into the tray: It loads and the tray opens after a few seconds again with no visual confirmation as explained on the website. This did the trick and the player is now DVD code free and plays the region code 1 discs that it did not play with only JB installed as explained on page 1.

Based on your and my experiences it is safe to say that the JB itself does not make a European Oppo 205 DVD region code free. Thanks to the Oppo Superdisc it can be done nonetheless but it would be easier if it would do with JB alone as stated in the feature table.

I have done a NAND backup before and after Superdisc and did a binary compare of all 23 files:

There are changes in only the file ubi0.bin, all other files are the same.
 

ChristianMSchneider

Novice Member
ChristianMSchneider,

Did you first do a NAND Backup?
Of course :)
After this RU JB install on your Oppo-205 EU unit, did you reset to factory settings?
Yes - and I pulled even the plug and it came up in Russian.
Did you test Blu-ray ISO playback from local USB HDD and network share?
I did not have an ISO of a Blu-ray handy so I downloaded one from Index of /durian/movies/ and copied it to a USB stick. The Blu-ray ISO plays from the USB stick.
Is this a clear indication that the JB is applied correctly (knowing that the DVD region code free did not work)?
I dont have a region coded DVD ISO to test, what was the DVD title that gave that Wrong Region Popup Error?
I could fix the DVD region code issue with the help of the Oppo superdisc as explained in my previous post.

Thank you for your help!
 

riki68

Novice Member
I would like to ask. This is my version of Clone OPPO M9702. In the attached image:

1622381445729.png



Is there any newer to update?
 

moremodey01

Active Member

ChristianMSchneider, well, looks like​

you resolved your issue.

Maybe moremodey1 can look into why this
happens and what changed in the ubi0.bin file.

Id still like to test mine.


riki68;​

Latest Jailbroken firmwares are 20XRU/20XCN 65-0131.
the oppo disk is just some weird trick from oppo, the content is not even used, all the player do is to check if the files /SUPER/SPECIAL_CONFIG.spe and /SUPER/FUNCTION_0.cfg exists when you mount a disc, if yes it write a value in the encrypted ACFG config that is located in the UBI partition (/mnt/ubi_boot , ubi0.bin in the dump)
 

theaxledentaldj

Active Member
Has anyone gotten their Late 2014 Mac mini that's running MacOS Bigsur 11.4 with NFS Manager 5.2 to allow their Oppo-203 to see NFS mounts? I've just tested this today and so far, my Oppo-203 will not see the NFS shares from NFS Manager 5.2 on MacOS 11.4. I can't even get NFS Manager to run the NFS server test because its complaining about IPv6 and try manually IPv4 address. I do see NFS Manager is only updated for MacOS 11.3. Its got me scratching my head. Incase I want to update my Mac mini to Monterey, my NFS shares must continue to work on my Mac mini with my Oppo-203.

Issue resoled. Seems NFS Manager glitched and wasnt exporting the NFS shares until I rebooted and restarted a fresh NFS Manager with a new config and the "Apply" button now shows up because before it wasnt there.
 
Last edited:

cle2000

Standard Member
Hi all,
first of all, many thanks to theaxledentaldj, moremodey01, Thomas Szucs, liwil for their high contribution to this forum.
It allowed me to install the RU jailbreak into my Oppo 203 (EU) by USB method and allowed me to learn a lot about autoscript.
Because i faced some freezes in Network menu or some movies shared on my network, i tried to use the original EU-65-0131 bdpprog with a simple autoscript in order to switch between the RU jailbreak and the official EU bdpprog. I didn't install the overlay but it's the same principle.
Unfortunatly, i noticed the same freezing issues, i mean the only solution is to power off my oppo an then power on again.
Then i decided to go back to official EU firmware and tried to do it by a simple way through USB and it worked !
How ? Just switch to the official EU bdpprog (with autoscript) in order to use the EU firmware and then put the official EU-65-0131 firmware (.bin) into an USB key and upgrade with the Oppo menu (answer yes when asking replacing the firmware with the same version). I'm sure that it worked because i verified in /usr/local/bin repository the presence of the official bdpprog (and not the JB RU script) and the absence of bdpprog.1 in the same directory.
Of course, files added (as EU bdpprog) in /mnt/ubi_boot/ are still present but they can be removed because not used by the official firmware.

So, i can confirm it's possible to revert to the official EU firmware by USB method.

And now ...
i will keep the official firmware for a few weeks and will check if i still have these freezes using network menu.
I already faced a freeze when watching "IP MAN 3" in french langage. So my opinion is that it's not due to the JB firmware but either by a bug in the official firmware or by an anomaly of my oppo.
So i will certainly re-install the RU JB firmware later.
 
Last edited:

theaxledentaldj

Active Member
cle2000,

Thats very creative.
I hope you did a NAND backup after this?

I'm curious to see if there's any change there?

I figured this method would work because the Oppo-203 EU bdpprog was back on Stock EU Firmware, so it saw it as original stock firmware which allowed the normal firmware update to replace with the same stock EU firmware again.

You should test your "Freeze" issue with those movie titles from local HDD. If they don't do it there, then my suspect would be the ethernet, network, router, NAS, or something between the network?

Im not saying Ethernet share nor local HDD share is 100% perfect in BD ISO and 4K UHD BD ISO playback because I sometimes get a hiccup, and when I do, I go back a few seconds to see if its repeatable, and its usually never repeatable unless its a bad file.

I have actual Blu-ray and 4K UHD BD discs, so I can test my Oppo-203 fully.
I also have CDR-Audio discs, but no DVDs.
 

cle2000

Standard Member
Thanks theaxledentaldj for your reply.
Yes i already made a nand backup before and after this operation.
I checked a lot of things : region, some BDs, and i just watched a movie from my NAS. Sounds good.
I'm completely sure that i use the official firmware.
Regarding my freezing issues, it arrived sometimes but it was rare. However, i reach to have this freeze at each time with "IP man 3" 4K mkv watched from my network but only with french DTS HD master audio : as you say perhaps a problem with this mkv file. I will do a test tomorrow with a local HDD .
 

theaxledentaldj

Active Member
cle2000, if its an MKV remux/container, then I'd blame it on whoever did the mkv. I wouldn't trust it.
Thats 1 reason why I no longer use mkv.
 

Thomas Szucs

Active Member
Hi all,
first of all, many thanks to theaxledentaldj, moremodey01, Thomas Szucs, liwil for their high contribution to this forum.
It allowed me to install the RU jailbreak into my Oppo 203 (EU) by USB method and allowed me to learn a lot about autoscript.
Because i faced some freezes in Network menu or some movies shared on my network, i tried to use the original EU-65-0131 bdprog with a simple autoscript in order to switch between the RU jailbreak and the official EU bdprog. I didn't install the overlay but it's the same principle.
Unfortunatly, i noticed the same freezing issues, i mean the only solution is to power off my oppo an then power on again.
Then i decided to go back to official EU firrmware and tried to do it by a simple way through USB and it worked !
How ? Just switch to the official EU bdprog (with autoscript) in order to use the EU firmware and then put the official EU-65-0131 firmware (.bin) into an USB key and upgrade with the Oppo menu (answer yes when asking replacing the firmware with the same version). I'm sure that it worked because i verified in /usr/local/bin repository the presence of the official bdprog (and not the JB RU script) and the absence of bdpprog.1 in the same directory.
Of course, files added (as EU bdprog) in /mnt/ubi_boot/ are still present but they can be removed because not used by the official firmware.

So, i can confirm it's possible to revert to the official EU firmware by USB method.

And now ...
i will keep the official firmware for a few weeks and will check if i still have these freezes using network menu.
I already faced a freeze when watching "IP MAN 3" in french langage. So my opinion is that it's not due to the JB firmware but either by a bug in the official firmware or by an anomaly of my oppo.
So i will certainly re-install the RU JB firmware later.
Great that you tested this - thanks. I had the same thought when the overlay was released but was not brave enough to test it. Talked with moremodey01 about it who was also uncertain about what would happen, so it never got further.
BTW: If someone still has an non-jailbreaked Oppo US, AU, HK version please pm me.
 

cle2000

Standard Member
So i did a try with a local HDD : same result with "IP Man 3" mkv, so clearly a faulty mkv file ! Thanks theaxledentaldj for the idea.
So from now, i will wait for some freezing issues when navigating in movies files tree of Network menu with official firmware. In any cases, i will make a report into this forum in a few weeks. I want to know if this is caused by the RU JB, or if it's due to an incorrect management of Official FW when the network is faulty, or if it's a hardware problem.
Have a nice day.
 
Last edited:

whirlpool

Active Member
cle2000,

Thats very creative.
I hope you did a NAND backup after this?

I'm curious to see if there's any change there?

I figured this method would work because the Oppo-203 EU bdpprog was back on Stock EU Firmware, so it saw it as original stock firmware which allowed the normal firmware update to replace with the same stock EU firmware again.

You should test your "Freeze" issue with those movie titles from local HDD. If they don't do it there, then my suspect would be the ethernet, network, router, NAS, or something between the network?

Im not saying Ethernet share nor local HDD share is 100% perfect in BD ISO and 4K UHD BD ISO playback because I sometimes get a hiccup, and when I do, I go back a few seconds to see if its repeatable, and its usually never repeatable unless its a bad file.

I have actual Blu-ray and 4K UHD BD discs, so I can test my Oppo-203 fully.
I also have CDR-Audio discs, but no DVDs.
I applied the Russian JB to my Oppo 203 in Dec 2020.
I have watched many DVDs, Blu-Ray and 4K UHD original movies since the jailbreak using folder playback and have seen only one freeze (WW 1984 4K UHD). Had to power off/on the Oppo.

Even played Gemini Man at 60Hz with no glitches.

I put that one freeze down to a network glitch. Replayed over the same time point in the movie with no glitch.

Good news that it’s possible to revert to stock firmware, but I still see no reason to at the moment.

My fileserver is an HP Proliant ML10 running Windows Server 2012 on a machine isolated from the internet (firewall disabled).
 
Last edited:

Thomas Szucs

Active Member
Good news that it’s possible to revert to stock firmware, but I still see no reason to at the moment.
Yes, for now you can go back to a EU, CN or RU stock firmware. For US, HK or AU firmware you would need a corresponding bdpprog. Don't think we have access to those.
 

Oxygen

Standard Member
So i did a try with a local HDD : same result with "IP Man 3" mkv, so clearly a faulty mkv file ! Thanks theaxledentaldj for the idea.
So from now, i will wait for some freezing issues when navigating in movies files tree of Network menu with official firmware. In any cases, i will make a report into this forum in a few weeks. I want to know if this is caused by the RU JB, or if it's due to an incorrect management of Official FW when the network is faulty, or if it's a hardware problem.
Have a nice day.

Just a hint of what could be the problem, i had this freeze thing also, network menus could be lagging and slow, but it was related to firewall settings, -running Windows 10 Enterprise 64bit. Even though you can connect to your network shared files sometimes when "streaming" it seem firewall blocks the connection making the "stream" to freeze. I had to disable "Block incoming NETBIOS requests". -Generally not recommended but i feel my network is safe :)
 

whirlpool

Active Member
Just a hint of what could be the problem, i had this freeze thing also, network menus could be lagging and slow, but it was related to firewall settings, -running Windows 10 Enterprise 64bit. Even though you can connect to your network shared files sometimes when "streaming" it seem firewall blocks the connection making the "stream" to freeze. I had to disable "Block incoming NETBIOS requests". -Generally not recommended but i feel my network is safe :)
Agreed, a blocking firewall could cause an occasional network glitch, also, using Windows 10 as a file server could cause a glitch if Windows 10 is momentarily carrying out some O/S related activity while serving a file.
I’m running Windows Server 2012 on a HP ML10 server isolated from the internet, so no need for a firewall, and a very lean O/S.
 

cle2000

Standard Member
Yes, for now you can go back to a EU, CN or RU stock firmware. For US, HK or AU firmware you would need a corresponding bdpprog. Don't think we have access to those.
Thomas, i know that you already asked to PM you if some guys have a non jailbreaked oppo US, HK or AU but just to explain to those guys, it 's very simple to retrieve the bdpprog :

You just need to make an Autoscript batch with a "cf.sh" file including those commands :
#! /bin/sh
cp /usr/local/bin/bdpprog /mnt/sda1/bdpprog
sync

Use a standard "Autoscript.TSS" in order to call "cf.sh" file :
SLEEPMS(1000)
CLI(CLI_exec /mnt/sda1/AutoScript/cf.sh)
SLEEPMS(1000)
CLI(CLI_exec sync)
CLI(CLI_drv.ir.rx.sq 0xaf000)

That will copy your stock bdpprog into the USB key attached.
Then if you agree, you will be abble to share it in this forum.
 
Last edited:

cle2000

Standard Member
Just a hint of what could be the problem, i had this freeze thing also, network menus could be lagging and slow, but it was related to firewall settings, -running Windows 10 Enterprise 64bit. Even though you can connect to your network shared files sometimes when "streaming" it seem firewall blocks the connection making the "stream" to freeze. I had to disable "Block incoming NETBIOS requests". -Generally not recommended but i feel my network is safe :)
Thanks a lot Oxygen, it makes sense : i will check my firewall settings.
 

cle2000

Standard Member
Agreed, a blocking firewall could cause an occasional network glitch, also, using Windows 10 as a file server could cause a glitch if Windows 10 is momentarily carrying out some O/S related activity while serving a file.
I’m running Windows Server 2012 on a HP ML10 server isolated from the internet, so no need for a firewall, and a very lean O/S.
Thanks a lot Whirlpool
 

theaxledentaldj

Active Member
cle2000, good idea. I could have done that on my 2nd Oppo but didnt.

I could make some AutoScripts and test them on my Oppo and update page 1 post 1 with them. Thanks!
 

The latest video from AVForums

LG C1 OLED TV Best Picture Settings for SDR, HDR and Dolby Vision
Subscribe to our YouTube channel

Latest News

Sky drops Sky One brand and introduces Showcase and Max
  • By Andy Bassett
  • Published
Cleer Audio announces Roam NC, affordable TWS earbuds
  • By Andy Bassett
  • Published
Toshiba smart TVs add Amazon Music and Twitch apps
  • By Andy Bassett
  • Published
Samsung launches Odyssey Neo G9 mini LED gaming monitor
  • By Andy Bassett
  • Published
LG adds to TONE Free earphone lineup for 2021
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom