Formatting USB sticks for use in flashing Humax firmware

raydon

Well-known Member
I'm posting here what I hope will be the definitive solution to the problem of USB sticks not working when attempting to reflash Humax firmware. This subject has probably generated more posts than any other in the Humax Foxsat related forums so hopefully this might just put an end to it. However, only time will tell.
logiciel, I hope you don't mind me posting this in the Freesat forum, but I thought this the best place since this is where the majority of queries have been generated regarding this long standing problem.

I have a 1GB USB stick which wouldn't work with my Foxsat and this is how I fixed it.

First you need to download the 'bootice' flash drive partitioning and boot sector utility from HERE .
It's a small, single .exe Windows utility that doesn't need to be installed and can be run from anywhere.

Plug the USB stick into your PC and start bootice.

bootice.jpg

Select your USB stick from the drop down menu then click on 'Parts Manage'

partitions.jpg

Select the partition then click on 'Reformat USB disk' Note, it was FAT32.

modej.jpg

Select 'USB-FDD mode' then click on 'Next'

optionsk.jpg

Select File System 'FAT16', enter a Volume Label, then click on 'OK'

confirm.jpg

Confirm your selection by clicking on 'OK'

successj.jpg

That's it. Done !

Close bootice and copy the firmware .hdf file to your newly formatted USB stick.
Hopefully, you will get the same result I did, a successful reflash !
 
Last edited:

logiciel

Moderator
Thanks raydon - it'll be useful for some Humax Freesat people so it's fine here - Logi.
 
Last edited:

Pyebald

Standard Member
Thanks for this info. I too had problems formatting USB disk. I had been using an 8gig SanDisk to transfer over files to Humax but could not use it for "hdf" upgrade Eventually got it using Bootice formatting and USB-HDD mode
 

mikatt

Active Member
Hi I am trying to get 4.0.7 up and running but no luck I have tried bootice to format a 1Gb usb stick it loads into the foxsat but when I address the foxsat from my pc it just shows the basics with no way of running the Web interface any help and advice would be appreciated.

Mike
 

raydon

Well-known Member
when I address the foxsat from my pc it just shows the basics with no way of running the Web interface any help and advice would be appreciated.

Mike
If you have succeeded in flashing the custom firmware you will see the message Custom FW v4.0.7 just after the BOOT message on the HDR's front panel.

By the basics, do you mean this ?

If so, just click on the Download & Install the Full Web Interface button.
basicv.jpg
 
Last edited:

mikatt

Active Member
Hi no it does not get that far just the 6 or 8 in number icons to access some of the system, half of them come up with fault number 404 I think it was

Mike
 

raydon

Well-known Member
Hi no it does not get that far just the 6 or 8 in number icons to access some of the system, half of them come up with fault number 404 I think it was

Mike
just the 6 or 8 in number icons to access some of the system ?? Sorry but you are not making yourself very clear here. Are you talking about the front panel display? When flashing the firmware, the front panel display will initially show 'BOOT' and then be followed by an incrementing series of numbers preceded by the letter 'P'. then 'END' when it's done.

From your browser, a #404 error just means the site is unavailable. i.e. You have not suceeded in flashing the custom firmware. Redownload the bundle in case your copy is corrupt. Try the smallest USB stick you have and format it to fat32 before copying the hdf onto it. If that doesn't work you really need to get another USB stick. It's as simple as that.
 
Last edited:

mikatt

Active Member
Hi further to my ealier post, I have now tried 4 different USB sticks rangeing from 250 Mbyt to 8 Gbyte. tried Bootice to format, my front panel display shows Custom Firmware v4.0.7.. When I then put the IP address on my browser I get the FoxSat up showing Browse Media files, Schedule Events, Web IF Channel list, EPG Now/Next, EPG 7 Days, Channel Editor, Service Manager, Package Manager, and Settings.clicking on each one in turn Shedule Events, EPG Now/Next, Service Manager, and Package Manager show error 404.
There is nothing further on the page I'm stumped??

Mike
 

REPASSAC

Well-known Member
Hi further to my ealier post, I have now tried 4 different USB sticks rangeing from 250 Mbyt to 8 Gbyte. tried Bootice to format, my front panel display shows Custom Firmware v4.0.7.. When I then put the IP address on my browser I get the FoxSat up showing Browse Media files, Schedule Events, Web IF Channel list, EPG Now/Next, EPG 7 Days, Channel Editor, Service Manager, Package Manager, and Settings.clicking on each one in turn Shedule Events, EPG Now/Next, Service Manager, and Package Manager show error 404.
There is nothing further on the page I'm stumped??

Mike
You have sucessfully flashed the firmware and installed the full interface from what you say. When you try the Package Manager link what shows in the Browser address bar and what browser and version are you using please.
Can you also verify (on the Foxsat) that the IP address you are using is current.

As you say you see the channel editor - you must have installed this - or perhaps you have in the past a previous installation?
 

mikatt

Active Member
Hi Repassac the address bar on selecting the package management is

192.168.0.102/pkg.shtml

my browser is Firefox v12.0

the IP address was checked on my Foxsat

and is 192.168.0.102

I didnt get as far as running the Web interface so maybe something had been loaded before but I have no recollection of that.

Mike
 

REPASSAC

Well-known Member
Hi Repassac the address bar on selecting the package management is

192.168.0.102/pkg.shtml

my browser is Firefox v12.0

the IP address was checked on my Foxsat

and is 192.168.0.102

I didnt get as far as running the Web interface so maybe something had been loaded before but I have no recollection of that.

Mike

Mike can you try and connect via ftp or telnet (if you know how) else try installing Filezilla and connecting using ID: root and the same password.

The Channel editor Icon should only appear if it has been installed.
 

mikatt

Active Member
Hi I installed Filezilla, but it appears I need the port address to my router to access the Foxsat how do I find that. It appears the packages I need most are Service management and Package management.

I installed a earlier firmware oo.15 I think it was and re installed 407 hopeing it would wipe everything and start again but no nothing changed makeing my 75 year old brain hurt ha. ha.

Mike
 

REPASSAC

Well-known Member
Hi I installed Filezilla, but it appears I need the port address to my router to access the Foxsat how do I find that. It appears the packages I need most are Service management and Package management.

I installed a earlier firmware oo.15 I think it was and re installed 407 hopeing it would wipe everything and start again but no nothing changed makeing my 75 year old brain hurt ha. ha.

Mike

You don't actually need the port number (It will default correctly to port 21).

When the firmware is installed on booting it will check the presence of a file /opt/etc/.DO_NOT_DELETE_THIS_FILE
If this exists it leaves things as they are including previous settings. However if it does not then it will clear out /opt and do a new install.

Just delete /opt/etc/.DO_NOT_DELETE_THIS_FILE and reboot.
 

mikatt

Active Member
Hi you've lost me here a bit, I have got the Foxsat running and can see it when looking at its IP address, I am running Filezilla it shows me my C and D discs I'm not clear where I look for the /opt/etc/.DO_NOT_DELETE_THIS_FILE file.??

Mike
 

REPASSAC

Well-known Member
Hi you've lost me here a bit, I have got the Foxsat running and can see it when looking at its IP address, I am running Filezilla it shows me my C and D discs I'm not clear where I look for the /opt/etc/.DO_NOT_DELETE_THIS_FILE file.??

Mike

Firstly with FileZilla you need to connect to the Foxsat using the quick connect fields at the top of the screen.
After you do this the right hand pane will be populated.
You can then see a folder opt - double click on it and it will open and you will see etc, double click on it and you will see .DO_NOT_DELETE_THIS_FILE file - Single click it to select it - Press right mouse button - select Delete.
 

mikatt

Active Member
Hi it says it requires Host name User name Password and Port

not clear what I have to enter

Mike
 

mikatt

Active Member
H i what I get is a small window opens with this request

Could not parse server address No host given please enter a host.

Mike
 

mikatt

Active Member
Hi by user name do you mean type the word root and password root sorry it comes back could not connect to server

Mike
 

GaseousClay

Member
Hi by user name do you mean type the word root and password root sorry it comes back could not connect to server

Mike
Yes. Are you entering the humax ip address correctly? you can check this on the device by selecting menu, scroll down to system then across to network and then press ok.
 

mikatt

Active Member
Hi yes I put in 192.168.0.101 but when I press quick connect it comes up Status connecting to 192.168.0.101:21 is this right

Mike
 

GaseousClay

Member
Hi yes I put in 192.168.0.101 but when I press quick connect it comes up Status connecting to 192.168.0.101:21 is this right

Mike
It certainly should confirm the status as you've reported but it should also almost immediately complete the connection process. My knowledge isn't that advanced to help further but I'm wondering if your computers firewall or anti-virus is blocking the connection? Perhaps disabling them temporarily might be an idea? Maybe someone else can add some assistance?
 
Last edited:

Partridge

Active Member
Hi yes I put in 192.168.0.101 but when I press quick connect it comes up Status connecting to 192.168.0.101:21 is this right
Mike, I'm not a network expert, but here you mention IP address is 192.168.0.101 whereas in the posts anove you had ....102. This may well be correct if your router is set up for automatic IP addresses ("DHCP"), but wanted to check that it wasn't a typo in the IP address causing the pain this morning when using FileZilla?
 

The latest video from AVForums

Samsung QN800B 8K TV Review
Subscribe to our YouTube channel

Latest News

Movies Podcast: 8th August 2022
  • By Casimir Harlow
  • Published
AVForums Podcast: 8th August 2022
  • By Phil Hinton
  • Published
Warner Bros Discovery set to combine Discovery+ and HBO Max
  • By Ian Collen
  • Published
What's new on Sky, NOW and Paramount+ UK for September 2022
  • By Andy Bassett
  • Published
Pro-Ject Audio launches X2 B turntable
  • By Ian Collen
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom