Quantcast

Firmware update advise please...

Placebo2

Novice Member
Hi Guys/Gals,

Ok, so I got a shiney new PSP on Saturday delivered next day from the good people at Movietyme.com Just have query regarding the firmware.

PSP came shipped with firmware version 1.51 installed already. Keen on the whole homebrewing stuff. I know that I have little chance at the moment with current firmware. Is it worth "upgrading" to 2.0 as any hack will be produced for this version first?

Hope this makes sense - any suggestions would be appricated.
 

chrislad

Well-known Member
Update. 1.51 will not be cracked as all the hackers are devoting their efforts to 2.0, which just took a major step a couple of days ago with the first homebrew code running on it. 1.51 is worthless, even if homebrew weren't an issue.
 

bellso

Well-known Member
Depends on what u want ffrom your PSP -if u want wireless web surfing, you need version 2.00.

There is downgrader from 1.52 to 1.50 if u google search [no idea if works on 1,51 though], if u really want to play ancient snes games and the like.

Sony will start releasing new games which will force u to have to have the newest version though, so wouldn't get too attached to the homebrew scene, until someone cracks it [hasn't happened with 2.00 yet afaik]
 

chrislad

Well-known Member
It has happened with 2.0. Winning Eleven 9 requires you to update to 2.0
 

Steven

Senior Moderator
It boils down to this: are you really that desperate to play old games from your childhood?

If however, your desire to play new PSP games is greater, upgrade. I updated my PSP as soon as I got home. If I ever felt nostalgic, thats what I keep my Nes, Snes, Megadrive and Game Gear around for ;)
 

zoidy

Active Member
bellso said:
There is downgrader from 1.52 to 1.50 if u google search [no idea if works on 1,51 though], if u really want to play ancient snes games and the like.
Sorry Bellso, but there is no downgrader available for 1.52 to 1.5. There is a half ars*d attempt by a dodgy cracker who stole other crackers ideas, but it doesn't actually work and the team the cracker was in are apparently now only concentrating on the demos scene.

Placebo2 - go with the upgrade to v2.0. You will get numerous benefits with the upgrade and there may possibly be some homebrew that works with 2.0 in the not so distant future.

LFC SL - totally agree with you there.
 

chrislad

Well-known Member
Spacecat said:
Not if you have a 1.5 and use the use the WAB updater you dont
That's a non-issue since he has 1.51 anyways. I know there's a WAB updater but it's not relevant here.
 
but the fact remains you DONT have to upgrade to 2.0 to play 2.0 games. he may be able to downgrade from 1.51 to 1.50.
So I would say it was relevant , just giving the guy all the info
 

chrislad

Well-known Member
If you are running 1.51, you DO have to upgrade (though there is a manual disc swapping method which is meant to bypass this) though. He's running 1.51, there is no downgrader, therefore I'm right :p
 

zoidy

Active Member
Spacecat said:
but the fact remains you DONT have to upgrade to 2.0 to play 2.0 games. he may be able to downgrade from 1.51 to 1.50.
So I would say it was relevant , just giving the guy all the info
And not to mention that there is currently no talk in the major forums about anyone creating a downgrader for 1.51, or even trying to crack 1.51 (or 1.52 for that matter). So the fact is that v2.0 is better than v1.51 in all respects (plenty of facts going around) and there is much more chance of us being able to run homebrew on v2.0 - especially from the news today:
http://psphacked.co.uk/cms/modules/news/article.php?storyid=88
 
Mate if i Were you I would leave NO STONE uncovered to see if a 1.51 downgrader is possible b4 upgrading to a 2.0?
 

robo989

Banned
Don't upgrade to 2.0 just yet!!!

Why?...

Well here's why, sure at the mo 1.51\1.52\2.0 are all as useless as each other as far as running homebrew is concerned. But although its only a guess its very likely that the 2.0 firmware is alot more secure and harder to crack for the groups than 1.51\1.52. Why else would sony have released it? If you think it was to give you new features then your tripping. The new features are there to entice you to update... :D

My PSP is at 1.52 and supposing the turns out the hackers can't fully crack 2.0 firmware, they will then turn to 1.52\1.51 obviously and focust their attentions on that...

Of course this is all hypothetical. But basically if I were you I'd wait a month longer to see what happens with this cracked 2.0 firmware.

I mean a .pdf reader has just been released you'll be kicking yourself if you find you've updated and if you hadn't you could try out all this new software - (if the scenario comes to light that the 2.0fw cannot be fully cracked but the 1.51\1.52 can)

Up to each person at the end of the day obviously, just make sure you think it thought before doing it!
 

MattTheBeanster

Active Member
robo989 said:
Why else would sony have released it? If you think it was to give you new features then your tripping. The new features are there to entice you to update... :D
Worked with me! The new movie format in v2 outstrips any thing i've seen on homebrew so far.
 

robo989

Banned
I have seen the difference in video quality on 2.0 firmware and tried the 2.0 firmware and the video is defo sharper and looks nicer...

I bought the PSP originally a couple weeks ago, but I'm visually impaired (I have permanent double vision and have lost all my peripheral vision - which sucks but hey life goes on)...

Anyway, I'm currently at the end of a course I'm doing some life skills at a college for the blind, my PSP had 2 dead pixels, but managed to get my mobility tutor to phone sony and do a swap for a PSP with no dead pixels and for them to check it before hand. So I thought I might as well try out firmware 2.0 since I'll be getting a new 1.52 one anyway.

And yes I agree the video looks nicer, but thats all that I noticed. I don't intend on buying UMDs, so its not a big deal.

Who know's I mean if it turns out none of the fw's can be cracked then I will update to 2.0 no reason not to.
 
SONy are doing a drip feed approach with the firmware.
Everything extra in 2.0 could have been in 1.0 its just to lock you in to what they want. personally the video playback is just fine for me as it is but each to their own.
 
K

kato670

Guest
Probably old news, but if you are interested in using the homebrew programs for the PSP it is now possible to downgrade from 2.0 to 1.50.
 

Similar threads

Trending threads

Top Bottom