Firewall hiding shared iTunes librarys

Discussion in 'iPhone Forum' started by Big Al, Nov 2, 2005.

Tags:
  1. Big Al

    Big Al
    Standard Member

    Joined:
    Jul 13, 2000
    Messages:
    247
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Sandhurst Berkshire UK
    Ratings:
    +1
    Hi

    I've set up my desk top computer as a music server using itunes 6 setting it up to share my entire library with my laptop.

    With McAfee firewall enabled I cannot see the shared library on my laptop. If I disable the firewall on both PCs I can see the shared library on my laptop. However if I enable the firewall on both Pc with iTunes running the shared library is still accessibile.

    What do I need to change in my firewall settings? iTunes.exe & iTunes helper are both allowed full access

    Big Al
     
  2. cwick

    cwick
    Active Member

    Joined:
    Feb 4, 2002
    Messages:
    2,231
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Reading
    Ratings:
    +95
    You'll need to allow TCP Port 3689 and UDP Port 5353.

    More here.
     
  3. Big Al

    Big Al
    Standard Member

    Joined:
    Jul 13, 2000
    Messages:
    247
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Sandhurst Berkshire UK
    Ratings:
    +1
    cwick

    Thanks very much. This worked a treat. Just added the ports to netgear routers firewall settings and all worked ok. Once again, many thanks

    Big Al
     
  4. cwick

    cwick
    Active Member

    Joined:
    Feb 4, 2002
    Messages:
    2,231
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Reading
    Ratings:
    +95
    Hmm, are you sure ? I would have thought it was the McAfee firewall that needed tweaking, not a netgear router ... surely you've just opened those ports to the internet ? Try quitting one of the copies of iTunes, and then opening it again to check it's really working.

    The tricky bit is the UDP - the part where iTunes finds out what other iTunes libraries are being shared (called "service discovery"). It's that bit that's usually blocked by software firewalls, and it's why it worked for you when you switched off McAfee. As soon as they've "discovered" each other a connection is made between the two iTunes, which is why you're able to restart the firewall and have the sharing keep working.

    Cheers, Carl.
     
  5. Big Al

    Big Al
    Standard Member

    Joined:
    Jul 13, 2000
    Messages:
    247
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Sandhurst Berkshire UK
    Ratings:
    +1
    Carl

    You're right. Upon statring iTunes it fails to see the shated library. The McAfee softwar has no options to alter thesettings you suggest, so it look like I might need a differnt firewall.

    Cheers

    Big Al
     

Share This Page

Loading...